# Admin page shows errors after upgrading to v3.5.3

**URL:** https://meta.discourse.org/t/v3-5-3/398634
**Category:** Self-hosting
**Tags:** unsupported-install
**Created:** [March 17, 2026, 1:02pm UTC](https://meta.discourse.org/t/v3-5-3/398634 "2026-03-17T13:02:41Z")
**Posts on this page:** 14
**Page:** 1

<div class="post-metadata">

### Author: ![xwj](https://avatars.discourse-cdn.com/v4/letter/x/f6c823/32.png) [@xwj](https://meta.discourse.org/u/xwj)
#### Post date: [March 17, 2026, 1:02pm UTC](https://meta.discourse.org/t/v3-5-3/398634/1 "2026-03-17T13:02:41Z")

</div>

The admin page is showing errors after upgrading from version v3.5.2 to v3.5.3

 ![5860ab90-c2f9-4d04-a228-c625c4f015e9](https://global.discourse-cdn.com/meta/original/4X/f/c/a/fca39c69a2812ce077783ae1c34ac2834399def9.png)

And reports the following error:

> loader.js:247 Uncaught (in promise) Error: Could not find module `discourse/admin/models/admin-plugin` imported from `discourse/plugins/docker_manager/discourse/models/repo`  
> at loader.js:247:1  
> at a (loader.js:258:1)  
> at s.findDeps (loader.js:168:1)  
> at a (loader.js:262:1)  
> at s.findDeps (loader.js:168:1)  
> at a (loader.js:262:1)  
> at requireModule (loader.js:24:1)  
> at n.i [as getRoute] (index.ts:121:18)  
> at p.\_getQPMeta (index.ts:101:20)  
> (anonymous) @ loader.js:247  
> a @ loader.js:258  
> (anonymous) @ loader.js:168  
> a @ loader.js:262  
> (anonymous) @ loader.js:168  
> a @ loader.js:262  
> requireModule @ loader.js:24  
> i @ index.ts:121  
> \_getQPMeta @ index.ts:101

It works normally after disabling plugins, but I can’t pinpoint which plugin is causing the issue. Can you help me take a look?

---

<div class="post-metadata">

### Author: ![xwj](https://avatars.discourse-cdn.com/v4/letter/x/f6c823/32.png) [@xwj](https://meta.discourse.org/u/xwj)
#### Post date: [March 17, 2026, 1:15pm UTC](https://meta.discourse.org/t/v3-5-3/398634/2 "2026-03-17T13:15:50Z")

</div>

The issue persists when “Disable unofficial client plugin customizations” is enabled in [Safe Mode](https://meta.discourse.org/t/53504?silent=true), but it works correctly when “Disable all client plugin customizations” is enabled.

---

<div class="post-metadata">

### Author: ![NateDhaliwal](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/natedhaliwal/32/313494_2.png) [@NateDhaliwal](https://meta.discourse.org/u/NateDhaliwal)
#### Post date: [March 17, 2026, 1:56pm UTC](https://meta.discourse.org/t/v3-5-3/398634/3 "2026-03-17T13:56:45Z")

</div>

3.5.3 is no longer supported. Please see [https://releases.discourse.org](https://releases.discourse.org).

---

<div class="post-metadata">

### Author: ![Heliosurge](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/heliosurge/32/571810_2.png) [@Heliosurge](https://meta.discourse.org/u/Heliosurge)
#### Post date: [March 17, 2026, 2:28pm UTC](https://meta.discourse.org/t/v3-5-3/398634/4 "2026-03-17T14:28:49Z")

</div>

As Nate said that is a very old version now. Maybe try a command line update.

---

<div class="post-metadata">

### Author: ![xwj](https://avatars.discourse-cdn.com/v4/letter/x/f6c823/32.png) [@xwj](https://meta.discourse.org/u/xwj)
#### Post date: [March 18, 2026, 1:54am UTC](https://meta.discourse.org/t/v3-5-3/398634/5 "2026-03-18T01:54:06Z")

</div>

Which version do you recommend upgrading to? Will skipping multiple versions cause more compatibility issues?

---

<div class="post-metadata">

### Author: ![xwj](https://avatars.discourse-cdn.com/v4/letter/x/f6c823/32.png) [@xwj](https://meta.discourse.org/u/xwj)
#### Post date: [March 18, 2026, 7:38am UTC](https://meta.discourse.org/t/v3-5-3/398634/6 "2026-03-18T07:38:15Z")

</div>

It failed immediately after upgrading to 2026.1.1

 ![157aba1d-af2c-48c0-851d-1fc82d27e1fa](https://global.discourse-cdn.com/meta/original/4X/4/d/d/4dd7c07f38fe599c6a0c9dd3998c069a43716895.png)

---

<div class="post-metadata">

### Author: ![merefield](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/merefield/32/176214_2.png) [@merefield](https://meta.discourse.org/u/merefield)
#### Post date: [March 18, 2026, 7:45am UTC](https://meta.discourse.org/t/v3-5-3/398634/7 "2026-03-18T07:45:34Z")

</div>

Check your `/logs` for suspect messages.

---

<div class="post-metadata">

### Author: ![Ed\_S](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ed_s/32/134015_2.png) [@Ed\_S](https://meta.discourse.org/u/Ed_S)
#### Post date: [March 18, 2026, 8:13am UTC](https://meta.discourse.org/t/v3-5-3/398634/8 "2026-03-18T08:13:33Z")

</div>

If the web upgrade fails, you need to use ssh to login as root and do a command line upgrade.

---

<div class="post-metadata">

### Author: ![xwj](https://avatars.discourse-cdn.com/v4/letter/x/f6c823/32.png) [@xwj](https://meta.discourse.org/u/xwj)
#### Post date: [March 18, 2026, 8:48am UTC](https://meta.discourse.org/t/v3-5-3/398634/9 "2026-03-18T08:48:19Z")

</div>

![7f64dae0-86c1-411e-bb8a-9a1f7a5573ff](https://global.discourse-cdn.com/meta/original/4X/3/8/5/38538e126e07482b5fd0ff690bad0049f3fa2bb7.png)

---

<div class="post-metadata">

### Author: ![darkpixlz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/darkpixlz/32/549896_2.png) [@darkpixlz](https://meta.discourse.org/u/darkpixlz)
#### Post date: [March 18, 2026, 8:50am UTC](https://meta.discourse.org/t/v3-5-3/398634/10 "2026-03-18T08:50:56Z")

</div>

Can you try a command line rebuild as the reply above suggests? That will likely fix it, I’ve never seen an issue from version jumps..

---

<div class="post-metadata">

### Author: ![xwj](https://avatars.discourse-cdn.com/v4/letter/x/f6c823/32.png) [@xwj](https://meta.discourse.org/u/xwj)
#### Post date: [March 19, 2026, 1:40am UTC](https://meta.discourse.org/t/v3-5-3/398634/11 "2026-03-19T01:40:52Z")

</div>

What is the specific command? My service is packaged into a Docker image and deployed on a remote server’s K8s cluster. The deployment uses the `web_only` method.

Additionally, when an error occurs on the administrator page, the following error message appears:

 ![b5f7482a-1271-4cbb-b836-d28a1c85ca12](https://global.discourse-cdn.com/meta/original/4X/8/9/6/89602a12a51b25d152a0a08f975eb8bc19f8fe6b.png)

---

<div class="post-metadata">

### Author: ![darkpixlz](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/darkpixlz/32/549896_2.png) [@darkpixlz](https://meta.discourse.org/u/darkpixlz)
#### Post date: [March 19, 2026, 1:42am UTC](https://meta.discourse.org/t/v3-5-3/398634/12 "2026-03-19T01:42:42Z")

</div>

> [@xwj](#):
>
> Could you please tell me the specific command?

Go to where you installed Discourse and type `./launcher rebuild app` - wherever `discourse_docker` is. I believe `/var/discourse` is the “recommended” place to put the script but it might be different for you.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 19, 2026, 2:07am UTC](https://meta.discourse.org/t/v3-5-3/398634/13 "2026-03-19T02:07:37Z")

</div>

> [@xwj](#):
>
> What is the specific command? My service is packaged into a Docker image and deployed on a remote server’s K8s cluster

That’s not supported. You’ll need to do something to load the latest image. You’ll need to migrate the database. There’s usually no problem upgrading multiple versions.

---

<div class="post-metadata">

### Author: ![xwj](https://avatars.discourse-cdn.com/v4/letter/x/f6c823/32.png) [@xwj](https://meta.discourse.org/u/xwj)
#### Post date: [March 19, 2026, 9:45am UTC](https://meta.discourse.org/t/v3-5-3/398634/14 "2026-03-19T09:45:13Z")

</div>

It seems the database migration failed. The following error was reported.

> TOP =\> db:migrate =\> assets:precompile:asset\_processor │  
> │ full trace by running task with --trace) │  
> │ executing /etc/runit/1.d/00-ensure-links │  
> │ executing /etc/runit/1.d/01-cleanup-web-pids │  
> │ executing /etc/runit/1.d/anacron │  
> │ executing /etc/runit/1.d/cleanup-pids │  
> │ stale PID files │  
> │ executing /etc/runit/1.d/copy-env │  
> │ runsvdir, PID is 1126 │  
> │ aborted! │  
> │ pnpm -C=frontend/asset-processor node build.js (Discourse::Utils::CommandError) │  
> │ Failed to switch pnpm to v10.28.0. Looks like pnpm CLI is missing at “/home/discourse/.local/share/pnpm/.tools/pnpm/10.28.0/bin” or is incorrect │  
> │ /home/discourse/.local/share/pnpm/.tools/pnpm/10.28.0/bin/pnpm EACCES

When I checked the specific pnpm path, I found that the path existed, but the `pnpm.cjs` file lacked execute permissions, which caused the error.

> drwxrwxrwx root root /  
> drwxr-xr-x root root home  
> drwxr-x— discourse discourse discourse  
> drwxr-x— discourse discourse .local  
> drwxr-x— discourse discourse share  
> drwxr-x— discourse discourse pnpm  
> drwxr-x— discourse discourse .tools  
> drwxr-x— discourse discourse pnpm  
> lrwxrwxrwx discourse discourse 10.28.0 → 10.28.0\_tmp\_9\_0  
> drwxr-x— discourse discourse 10.28.0\_tmp\_9\_0  
> drwxr-x— discourse discourse bin  
> lrwxrwxrwx discourse discourse pnpm → ../node\_modules/pnpm/bin/pnpm.cjs  
> drwxr-x— discourse discourse ..  
> drwxr-x— discourse discourse node\_modules  
> drwxr-x— discourse discourse pnpm  
> drwxr-x— discourse discourse bin  
> -rw-r----- discourse discourse pnpm.cjs

Later, after pre-installing the corresponding version of pnpm using `corepack` in the image, the database migration succeeded. The service is now normal.
