# Very frequent 500 errors after server reinstallation

**URL:** https://meta.discourse.org/t/very-frequent-500-errors-after-server-reinstallation/183049
**Category:** Support
**Created:** [March 12, 2021, 7:06pm UTC](https://meta.discourse.org/t/very-frequent-500-errors-after-server-reinstallation/183049 "2021-03-12T19:06:30Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![SilviaB](https://avatars.discourse-cdn.com/v4/letter/s/cdc98d/32.png) [@SilviaB](https://meta.discourse.org/u/SilviaB)
#### Post date: [March 12, 2021, 7:06pm UTC](https://meta.discourse.org/t/very-frequent-500-errors-after-server-reinstallation/183049/1 "2021-03-12T19:06:30Z")

</div>

Hello everyone,

I had to rebuild a Discourse server only from the backup file after having lost the initial server and its snapshots (in a fire on the hosting site, God bless backups off-site!). The initial server was on Ubuntu 19.04 and not with the latest version of Discourse on it (maybe a couple of months behind, I do not recall the exact version). I have now installed the newest version of Discourse on an Ubuntu 18.04 and had restored the database from the UI using the last backup file.

The site is now experiencing frequent 500 errors and I see two types of error messages in the production log. Could you please help me with some ideas of what I could do next? Many thanks!

Started GET “/t/en-2019-des-frontaliers-imposes-a-la-source-en-france/8675” for xx.xx.xx.xx at 2021-03-12 07:57:02 +0000  
Processing by TopicsController#show as HTML  
Parameters: {“slug”=\>“en-2019-des-frontaliers-imposes-a-la-source-en-france”, “topic\_id”=\>“8675”}  
Completed 500 Internal Server Error in 145ms (ActiveRecord: 0.0ms | Allocations: 30586)  
NoMethodError (undefined method `slow_mode_seconds' for #<Topic:0x00007f9f56b4c1f0>) (eval):2:in `slow\_mode\_seconds’  
(eval):33:in `_fast_attributes' app/controllers/topics_controller.rb:1109:in `block (2 levels) in perform\_show\_response’  
app/controllers/topics\_controller.rb:1104:in `perform_show_response' app/controllers/topics_controller.rb:162:in `show’  
app/controllers/application\_controller.rb:358:in `block in with_resolved_locale' app/controllers/application_controller.rb:358:in `with\_resolved\_locale’  
lib/middleware/omniauth\_bypass\_middleware.rb:68:in `call' lib/content_security_policy/middleware.rb:12:in `call’  
lib/middleware/anonymous\_cache.rb:353:in `call' config/initializers/100-quiet_logger.rb:23:in `call’  
config/initializers/100-silence\_logger.rb:31:in `call' lib/middleware/enforce_hostname.rb:23:in `call’  
lib/middleware/request\_tracker.rb:177:in `call’

Started GET “/” for xx.xx.xx.xx at 2021-03-12 07:55:24 +0000  
Processing by CategoriesController#index as HTML  
Completed 500 Internal Server Error in 313ms (ActiveRecord: 0.0ms | Allocations: 69745)  
NoMethodError (undefined method `default_list_filter' for #<Category:0x00007f9f520dc778> Did you mean? default_view) (eval):29:in `\_fast\_attributes’  
lib/freedom\_patches/ams\_include\_without\_root.rb:57:in `include!' app/controllers/categories_controller.rb:42:in `block (2 levels) in index’  
app/controllers/categories\_controller.rb:40:in `index' app/controllers/application_controller.rb:358:in `block in with\_resolved\_locale’  
app/controllers/application\_controller.rb:358:in `with_resolved_locale' lib/middleware/omniauth_bypass_middleware.rb:68:in `call’  
lib/content\_security\_policy/middleware.rb:12:in `call' lib/middleware/anonymous_cache.rb:353:in `call’  
config/initializers/100-quiet\_logger.rb:23:in `call' config/initializers/100-silence_logger.rb:31:in `call’  
lib/middleware/enforce\_hostname.rb:23:in `call' lib/middleware/request_tracker.rb:177:in `call’

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [March 12, 2021, 7:18pm UTC](https://meta.discourse.org/t/very-frequent-500-errors-after-server-reinstallation/183049/2 "2021-03-12T19:18:17Z")

</div>

> [@SilviaB](#):
>
> `slow_mode_seconds`

How did you install Discourse itself? Was it following [Discourse official Standard Installation]([Install Discourse in production with the official supported instructions](https://meta.discourse.org/t/discourse-official-standard-installation/142537))?

Can you link the site?

---

<div class="post-metadata">

### Author: ![SilviaB](https://avatars.discourse-cdn.com/v4/letter/s/cdc98d/32.png) [@SilviaB](https://meta.discourse.org/u/SilviaB)
#### Post date: [March 16, 2021, 3:13pm UTC](https://meta.discourse.org/t/very-frequent-500-errors-after-server-reinstallation/183049/3 "2021-03-16T15:13:36Z")

</div>

Thanks a lot, @Falco! Your suggestion took me to the solution.  
Indeed I was not following the installation procedure, more precisely I was not passing through the initial discourse setup (with the discourse-setup command).  
I was just using a “launcher rebuild” command with the configuration file taken from the previous install.

Using discourse-setup allowed me to recreate the config file from scratch and then I modified it to add my custom paths and plugins, did a rebuild and everything worked as before.

Thanks again for your help!

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [April 17, 2021, 2:55pm UTC](https://meta.discourse.org/t/very-frequent-500-errors-after-server-reinstallation/183049/5 "2021-04-17T14:55:28Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
