Videos used to play, now only links available


(Susan Spencer) #1

Can someone provide help with embedded video settings?
Obviously something changed, but I can’t locate the setting that fixes this problem:
Our videos are now only downloadable links, they previously were playable within the post.

Current behavior:

Previous behavior:


(Jeff Atwood) #2

Is flash video embedding enabled in your site settings?


(Susan Spencer) #3

Today I tried posting with .mp4 and with .flv, both had worked in the past. The rotate dart example is MP4. I used FLV during troubleshooting today because of the explicit option to support .flv in Onebox. This option has not been changed.


(Jeff Atwood) #4

MP4 video

http://www.sample-videos.com/video/mp4/720/big_buck_bunny_720p_1mb.mp4

That embeds just fine. Can you test the flash site setting @techapj?


(Susan Spencer) #5

hmmm just noticed that the links to posts aren’t Oneboxed either:


(Joshua Rosenfeld) #6

Is that a link to your own forum? I’m having difficulties on my forum with internal oneboxing all of a sudden too:

Does this apply to you?


(Jeff Atwood) #7

I can’t repro this on try.discourse.org – when I upload the big buck bunny mp4 video (linked above), it embeds fine.


(Jeff Atwood) #8

I can, however, confirm embedding .flv videos no longer seems to work @eviltrout.

Even with flv filetype enabled and the site setting to allow flash embedding, I can’t get the file to show as a flash video.

@slspencer your workaround, for now, is to upload the flash videos to youtube and embed them that way. That’s much better than a flash video embed anyway, which won’t work at all on any iOS or Android device!


(Susan Spencer) #9

Thanks everyone.
I haven’t resolved this, I don’t know how Digital Ocean resolves internal links.
Also, I’m not a fan of .flv but usually use .mp4. I converted my .mp4 to .flv as a test when I noticed that the .mp4 didn’t embed.
I would prefer to have our videos stored on our DO, not YouTube, so that we can organize them better and create a proper library (eventually). In any case we still have the links which lack user impact but they still work. And Oneboxing of our forum posts did get people’s attention, but again the links still work.

Any idea why this started recently, maybe a change at DO?


(Jeff Atwood) #10

OK, but why not both? Why does it have to be one or the other?

I tested on a droplet using Digital Ocean, but I use a CDN there, so the link is still not an internal one. Another solution for you is to set up a CDN, which will speed up access to your site and its assets worldwide as an ancillary benefit.


(Susan Spencer) #11

Cloudflare burned us bad, their proprietary protocol stopped communicating with our site but they would not troubleshoot as we’re a free customer. Took days to uncouple from Cloudflare, they wouldn’t even update their DNS tables after we dropped them. Right now I’m just not a fan of CDN. Maybe we’ll look into this again later :slight_smile:


(Susan Spencer) #12

And because our training will eventually be in a paid-area on our forum


(Robin Ward) #13

I can’t seem to get flash to install on my computer in any workable way (I’ve tried installing and re-installing with no luck.)

Having said that, I was able to confirm that if I enable flash video, it’s outputting the <embed> tag for the video. Is that no longer sufficient to render the video?


(Jeff Atwood) #14

Cloudflare is not a CDN in the traditional sense. Try looking at KeyCDN, MaxCDN, CDN77, and so on.

@eviltrout if you can’t repro that part can be ignored.


(Jean Denis Boivin) #15

Have a similar issue, I have site A and B, hosted on the same server, sharing the same IP but have different sub-domain name. Site A is my Discourse forum, Site B is just a site with pages that can get oneboxed.

Since I did a rebuild, I can’t get links from Site B to get oneboxed on Site A, was working fine before, and if I try to paste it here, it works.

Edit: I’ve rebuild back to 1.9.0.beta1 and everything works fine, so definitively something’s weird going on with the latest update, so either my NGINX config don’t play nice with beta2 or domain with the same IP can’t get oneboxed?

Edit 2: I’m not sure what exactly is going on, but I rebuild to latest version, do some tests, everything seems to works fine again, run a “rake posts:rebake” to get the links oneboxed, and now suddenly then don’t want to get oneboxed

Edit 3: Also get a lots of

Failed to rebake (topic_id: 15191, post_id: 95337)
MISCONF Redis is configured to save RDB snapshots, but is currently not able to persist on disk. Commands that may modify the data set are disabled. Please check Redis logs for details about the error.

Not sure if related, maybe it’s my server choking or something


(Robin Ward) #17

I am fairly certain your issue is affected by the issue outlined in this post. You can whitelist your hosts to fix it.


(Jean Denis Boivin) #18

Yes, since adding the domains to the whitelist, the problem seems to be resolved, thanks!