Viewing Privacy Policy Without Logging In?


(Safa Faheem) #1

I currently have a footer on my home page that links to the Terms and Privacy Policy. The Terms link works okay whether or not the user is signed in, but the Privacy Policy only appears once the user logs in. Is there a way to get around this? I want the user to be able to see the privacy policy even when they are signed in.

Let me know if you need any other details. Appreciate the help.


Infinite spinner /about on private forum when logged out
(Kane York) #2

Hmm? Works fine for me…


(Safa Faheem) #3

Hi Riking,

Thanks for your response. Could you test it out on my website, and let me know if it works for you? I am unable to get to the privacy (link in the footer) without logging in. I also manually typed in the URL and was redirected back to the home page. Is there something in my code for this that I can fix?

https://app.myurologydoctor.com/login

Safa


(cpradio) #4

It seems you have login required enabled, thus preventing access to anything other than the welcome message you have shown.


(Safa Faheem) #5

Sorry, may be a stupid question, but where would I go to change that?


(Simon Cossar) #6

On my site with login required an anonymous user can access the FAQ, Terms of Service, and Privacy page. But not the about page.


(Safa Faheem) #7

Hi Simon,

So, is it something with my settings that an anonymous user cannot access my Privacy page?

Safa


(Joshua Rosenfeld) #8

Interestingly, I can load the FAQ, and the Terms of Service, but the privacy page redirects to the welcome message, and the about page loads indefinitely.


(Simon Cossar) #9

I’m not sure. One difference I can see between your site and mine is that you’re using https.

Also, the link in the footer is https://app.myurologydoctor.com/t/privacy-policy/6 and it should be https://app.myurologydoctor.com/privacy to allow for anonymous access. But I tried that and it still doesn’t work.


(Simon Cossar) #10

Make sure you haven’t set anything under SiteSettings privacy policy url. If you have, reset it and change the link in the footer to https://app.myurologydoctor.com/privacy


(Safa Faheem) #11

You are awesome, Simon! It works now. :slight_smile: