# デフォルトのウォッチが大量のメールをトリガー - default\_watch\_categories

**URL:** https://meta.discourse.org/t/watch-default-triggered-huge-volume-of-emails-default-watch-categories/271372
**Category:** Bug
**Created:** [2023 年 7 月 12 日午前 9:26 UTC](https://meta.discourse.org/t/watch-default-triggered-huge-volume-of-emails-default-watch-categories/271372 "2023-07-12T09:26:31Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![agemo](https://avatars.discourse-cdn.com/v4/letter/a/ac91a4/32.png) [@agemo](https://meta.discourse.org/u/agemo)
#### Post date: [2023 年 7 月 12 日午前 9:26 UTC](https://meta.discourse.org/t/watch-default-triggered-huge-volume-of-emails-default-watch-categories/271372/1 "2023-07-12T09:26:31Z")

</div>

**3.1.0.beta5 - [09feb03056]**

* * *

`default_watch_categories` がデフォルト（何も設定されていないはず）から単一のカテゴリに設定されました。これはおそらく史上初のことです。

これにより大量のメールが送信され、3日間で約40万件のメール再試行が処理された可能性があり、そのうち09%が失敗しました。ごく初期の段階で、これがSMTPプロバイダー側のレート制限を引き起こしました（これにより、意図しない莫大なメール料金請求が回避されました！）。

`default_watch_categories` 設定は、誤って設定されたため、リセットされました。

しかし、SMTPプロバイダーのレート制限がまだ有効であったため、Sidekiqでは依然として大量のメール再試行が表示されており、失敗し続けながらも試行を繰り返していました。

詳しく調べると、`default_watch_categories` がデフォルトにリセットされたにもかかわらず、1つの投稿が同じメールを何度も繰り返しトリガーし、数百、そして数千回も再試行しているように見えました。一体何が起こっていたのでしょうか？

その投稿と、それ以下の投稿が、通常のモデレーション上の理由で独自の「新しい」トピックに分割されたところ、ボーナスとしてメールトリガーと再試行が完全に停止しました。もう再試行はありません。

SMTPプロバイダーのレート制限に感謝！

---

<div class="post-metadata">

### Author: ![agemo](https://avatars.discourse-cdn.com/v4/letter/a/ac91a4/32.png) [@agemo](https://meta.discourse.org/u/agemo)
#### Post date: [2023 年 7 月 12 日午前 9:39 UTC](https://meta.discourse.org/t/watch-default-triggered-huge-volume-of-emails-default-watch-categories/271372/2 "2023-07-12T09:39:16Z")

</div>

追加の洞察として、これはSMTPプロバイダーの制限により、失敗したときにのみ検出されました。ダッシュボードに、過去7日間、24時間、および1時間のメール送信アクティビティのより明確な表示と、急増に対するアラートがあれば歓迎されるかもしれません。

このようなことは、経済的に大きな問題を引き起こす可能性があります。

プロバイダーがレート制限を導入しなければ、これは数日で年間ホスティング費用を使い果たしていた可能性があります！🤪

---

<div class="post-metadata">

### Author: ![kris.kotlarek](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kris.kotlarek/32/176919_2.png) [@kris.kotlarek](https://meta.discourse.org/u/kris.kotlarek)
#### Post date: [2023 年 7 月 13 日午前 1:16 UTC](https://meta.discourse.org/t/watch-default-triggered-huge-volume-of-emails-default-watch-categories/271372/4 "2023-07-13T01:16:45Z")

</div>

Hey @agemo

あなたのインスタンスでこのサイト設定を確認していただけますか？

 ![admin setting](https://global.discourse-cdn.com/meta/original/4X/b/6/6/b66ff47123168f52dcbe5ebe4f5f2dd34718d7c6.png)

これはユーザーのデフォルト設定です。ユーザーはプロフィールでこれを上書きできます。

 ![user setting](https://global.discourse-cdn.com/meta/original/4X/4/2/2/4226349732e3659ac7bf9860fb143186ef9696a8.png)

考えられる原因は以下の通りです。

1. デフォルト設定が「常に」または「不在時のみ」になっている。
2. ウォッチ対象カテゴリでトピックが作成された。システムは全ユーザー/不在ユーザーに通知しようとした。
3. レート制限によりクラッシュするSidekiqジョブが多数キューイングされた。
4. デフォルトのウォッチ対象カテゴリが削除されたが、既にキューイングされたSidekiqジョブは削除されていない。
5. Sidekiqは失敗したジョブをリトライする。
6. 投稿が新しいトピックに移動された際、以前に誤って作成された通知は削除された。
7. 通知が削除された際、リトライジョブはメールを送信せずに正常に完了した。

---

<div class="post-metadata">

### Author: ![agemo](https://avatars.discourse-cdn.com/v4/letter/a/ac91a4/32.png) [@agemo](https://meta.discourse.org/u/agemo)
#### Post date: [2023 年 7 月 13 日午前 10:06 UTC](https://meta.discourse.org/t/watch-default-triggered-huge-volume-of-emails-default-watch-categories/271372/5 "2023-07-13T10:06:20Z")

</div>

`default_email_level` : 離席時のみ

`deafult_email_message_level` : 無効
