Web upgrades failing with ESRCH: No such process

Starting with v2.4.0.beta10 +1 my web upgrades fail consistently with a “Sorry, there was an error upgrading Discourse. Please check the logs below”. See attached log for 2.5.0.beta2. Most of that is abracadabra to me, but that “#<Errno::ESRCH: No such process>” sounds bad. It is always that error.

A ./launcher rebuild app always does the job. But how can I fix the web upgrade?

This is on my test system, self-hosted at home. Intel Atom D525 1,8 Ghz 2 cores / 4 threads with 4 GB and SSD running Lubuntu 16.04 LTS. Just Docker/Discourse, no other tasks. Web upgrades worked flawless for almost 2 years before this.

In the course of this older topic, some people are reporting the same error, but the topic does not end with a conclusion about what is problem is.

2.5.0.beta2-fail.txt (10.2 KB)

********************************************************
*** Please be patient, next steps might take a while ***
********************************************************
Cycling Unicorn, to free up memory
Restarting unicorn pid: 637
Waiting for Unicorn to reload.
Waiting for Unicorn to reload..
(etc, etc)
Waiting for Unicorn to reload...........................................................
Stopping 3 Unicorn worker(s), to free up memory
Stopping job queue to reclaim memory, master pid is 671
Docker Manager: FAILED TO UPGRADE
#<Errno::ESRCH: No such process>
/var/www/discourse/lib/demon/base.rb:73:in `kill'
/var/www/discourse/lib/demon/base.rb:73:in `stop'
/var/www/discourse/lib/demon/base.rb:22:in `block in stop'
/var/www/discourse/lib/demon/base.rb:21:in `each'
/var/www/discourse/lib/demon/base.rb:21:in `stop'
config/unicorn.conf.rb:95:in `block (2 levels) in reload'
/var/www/discourse/plugins/docker_manager/lib/docker_manager/upgrader.rb:62:in `kill'
/var/www/discourse/plugins/docker_manager/lib/docker_manager/upgrader.rb:62:in `upgrade'

It’s not uncommon (i.e., a few times a year) that you need to do a command line up grade to get a new base container. If you have to do command line upgrades at every upgrade right now, I’d blame a plugin.

We don’t have any plugin. It happened with the last 4 upgrades.