Welcome User Email not being sent


#1

I have updated the WELCOME USER email template. However this is not being sent to the user as an email.

How can we get this email sent to the users?

Joe


(Jeff Atwood) #2

I am not aware of any welcome email that is ever sent in Discourse. And remember that we don’t email people who are actively pinging the site with a live web browser either.


#3

Im confused? Why would there be an email template called WELCOME USER if no email is ever sent?

I have many users that never login and only get updates via email so it would be helpful if they got the Welcome User email


(Jeff Atwood) #4

Sorry, no such function exists in Discourse.


(Vinoth Kannan) #5

You may enable default email always site setting from admin. It will send email message for notifications even when the user is active. Still this functionality is not limited to “Welcome User” message. Also you have to change the discourse narrative bot welcome post type site setting to achieve this.


(Jeff Atwood) #8

Again there is no user greeting. Vinoth is referring to the narrative bot which also never sends email by design as it is designed to be an interactive narrative answered natively in Discourse as a PM.


(Emma Furtado) #11

hello @joco
I was wondering the same thing a few weeks ago. This information might be helpful to you:
If you search for the site setting ’ discourse narrative bot welcome post type’ and select ‘Send all new users a welcome message with a quick start guide’, new users will receive a notification that uses the Welcome User email template. They will receive this as a notification when they first visit the forum. I don’t see an option to automatically send the notification as an email.


(Jeff Atwood) #13

Correct, there is no way to force this to be sent as an email to new users. Unless you default all users to duplicate notifications even when their web browser is pinging the server, which would be extremely invasive.


#14

Ok so how do I turn that on? Since none of my users access the website it would not be a problem


(Jeff Atwood) #15

Ok sorry for the confusion follow @communitygal’s advice she is correct!


#16

Yea I did what she said and still no emails being sent


(Jeff Atwood) #17

This implies the users are hitting the website, which prevents emails from being sent as duplicate notifications.


#18

Ok but I disabled that using the default email always


(Emma Furtado) #19

I’m guessing it will work for new users. Maybe create a new account and test?


#20

Yes thats what I did… I created new users it shows up in the PM but no email is sent.


#21

How do you know it shows up as a PM unless you log on though?