When we rebuild, we get the following error. can someone help me?

When we rebuild, we get the following error. can someone help me?

cd /var/discourse
./launcher rebuild app

FAILED
--------------------
Pups::ExecError: su postgres -c 'psql discourse -c "alter schema public owner to discourse;"' failed with return #<Process::Status: pid 1660 exit 2>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params "su postgres -c 'psql $db_name -c \"alter schema public owner to $db_user;\"'"
1 Like

run the follow cmds for me and see if it helps

apt-get update
apt-get upgrade

after that, then run

cd /var/discourse
./launcher rebuild app
1 Like

i run :
apt-get update
apt-get upgrade

but not found

[root@45 ~]# apt-get update
-bash: apt-get: command not found
[root@45 ~]# apt-get upgrade
-bash: apt-get: command not found

what os are you running ?

maybe try sudo apt-get update & sudo apt-get upgrade

1 Like

Thank you very much, we have successfully updated.
However, we use Centos, so we have:
yum update

4 Likes

Can you rebuild now?

1 Like

yes, rebuild successful,
if you have the same error as me, you can follow this solution,
yum update

1 Like