When you create a new category you're greeted with a blank page


(John Reid) #1

After you create a new category, the category should load.

BUT the page is redirected and the new category doesn’t load. You just have a blank page instead.

Sadness ensues.

Haiku ends.


(Jeff Atwood) #2

No repro. Here’s screenshots of me creating a new category on my Discourse instance:

And then after clicking “Create Category”, I get redirected to… drumroll, please…

Maybe update to latest?


(John Reid) #3

Ahhhh! You got me there :smile:

The IMPORTANT piece of information which breaks it is…

drumroll… Modify the permissions! Cymbol splash!

It seems just by adding trust_level_2, trust_level_3 or staff and then creating the category the page redirect breaks. Oddly - trust_level_1 systematically works. Creating categories with no security modifications also works.

And for completeness…

<!-- Discourse Version: 0.9.9.10 -->
<!-- Git Version: fba0958486a8a873d7fd26ddc4276ef51799c553 -->

(Régis Hanol) #4

Would you mind sharing the steps you used to reproduce this issue?

I just tried creating a new category with permissions and it worked just fine.


(John Reid) #5

Hmm, it’s started behaving for me which is annoying.

A surefire way to break it though - remove the everyone permission and replace it with something else. This chucks out a 403 error:

"NetworkError: 403 Forbidden - http://domain.com/category/test-test"

(Régis Hanol) #6

Are you on latest? I just tried on http://try.discourse.org and it worked just fine.


(John Reid) #7

0.9.9.10 - as above :wink:


(Régis Hanol) #8

Sorry I missed that :smile:

That git commit is from Feb, 14… You should definitely update.


(John Reid) #9

No worries - the amount of catastrophic things I’ve got wrong by misreading something… :open_mouth:

Anyway…

I wouldn’t read too much into the Git version - that’s definitely wrong. I’m running on DiscourseHosting.com and they are definitely up-to-date.

I’m in the middle of setting up a dev environment for myself but just haven’t finished it off. Things like time, space, family and the rest of the universe keep getting in the way, so all of what I’m finding is based on the updates they make on my production site. Best I can do at the moment.

I’ll drop them a line and let them know that they have the wrong Git info though.


(Jeff Atwood) #10

Regardless we cannot repro, get your host to update to latest.


(Jeff Atwood) #11