Which Ruby version is supported?

(Nilesh Trivedi) #1

I understand that the docker container includes all dependencies. But which Ruby version should I use in the development environment? Will 2.2 (released last night on 25th December) work? How about 2.1.5?

.ruby-version.sample mentions ruby-2.0.0-p195 even though Ruby 2.0.0 is now up to p598 apparently.

(Erick Guan) #2

Go ahead with 2.1.5. But not 2.2 this time since some gems have some issues with 2.2

In development, use rvm.

(Don Fletcher) #3

Does Discourse require Ruby 2.x? or will it work with Ruby 1.9.2?

(Rafael dos Santos Silva) #4

Discourse require 2.3.X now.

(xiasummer) #5


I tried

sudo apt-get update
sudo apt-get upgrade

But the ruby is still 1.9.x.

How to upgrade ruby to 2.1.x?