Windows 10 Edge browser not given the option to use mobile view


(ljpp) #1

Just noticed that when I browse my Discourse site on a 7" Windows 10 tablet using the Edge browser, I don’t have the option in the menu to use mobile view. If I swtich to Chrome on the same device, the option is available. Due to performance reasons Edge is a much better browser on these cheapo tablets, though.

Also a side note that the writing mode of the desktop view does not really work with this configuration. The touch keyboard gets in the way and an iPad-like solution might be needed.


(Joshua Rosenfeld) #2

What menu are you referring to? The Edge menu, or a menu on the Discourse software?


(ljpp) #3

Discourse burger menu.


(Joshua Rosenfeld) #4

Hmm, never noticed a mobile view link in that menu, but I also don’t have a 7" tablet. Sorry, no help from me :frowning:


(Luke S) #5

Hmm… Seems that the link is added based on OS? Definitely shows up for me on Android, even though I’m running a 10" tablet. You can manually force the edge browser to display the mobile version by appending ?mobile_view=1 to the end of the site URL. (So you can at least test how it works on win 10)

Try turning your tablet to portrait mode, works much better for me. Or do you mean that the keyboard covers parts of the composer? That might be worth a screenshot…


(Jeff Atwood) #6

JavaScript performance is no better than IE11 for Ember apps in Edge. I don’t recommend Edge for that reason as we are a JavaScript / Ember app.


(ljpp) #7

Ok, but this is a UI issue and not a performance issue - it runs fine. And besides, you are basically out of options on a 7" Baytrail tablet.


(Jeff Atwood) #8

Just a note, as of Windows 10 anniversary update about 1 week ago, ember and JS perf is 1.5x - 2x better in Edge, rather than being identical to IE11 as it was… per http://emberperf.eviltrout.com/

Render Complex List, Ember 1.12:

Edge → 124ms
IE11 → 173ms

Render Complex List, Ember 2.10:

Edge → 84ms
IE11 → 110ms