Wordpress not displaying Avatars


(Damien Bowman) #1

I’m newish here, but did a search and couldn’t find this issue. Wordpress and Discourse are both behind Memberful, but more importantly, the Wordpress site is HTTPs and Discourse is HTTP. Whenever we comment on a column, we see broken avatars. I checked the image source and the avatars are trying to pull HTTPs instead of HTTP.

This is similar to, but not exactly the same as Emojis Not Displaying / Old Avatar Styles, so I’m hoping for a quick solution and/or some suggestions. I did not try the re-write because I’m not sure it will work, but can try if anyone thinks that will work. I’d need to know where to put the re-write and the text to insert.

Wordpress site with comment: https://www.campuspressbox.com/2016/leonard-fournette-skipping-2016-silly/ The comment is at the bottom.

Thanks.


(Jeff Atwood) #2

HTTP within HTTPS is not going to work well.

I suggest adding HTTPS to your Discourse.


(Damien Bowman) #3

My thoughts exactly, but I send all the media through CloudFront, so I have to buy a cert for that? The WordPress SSL is through Cloudflare.


(Kane York) #4

You could just put Discourse through CF.


(Damien Bowman) #5

assume CF means CloudFlare not CloudFront?


(Kane York) #6

Yeah, missed that you said both of those. I meant CloudFlare.

Make sure to add templates/cloudflare.template.yml to your container definition after web.


(Damien Bowman) #7

Appreciate the help @riking. Two quick questions, I sent all the assets or whatever to CloudFront already, so if I change the config will existing photos work or will everything be broken?

Next, I’m somewhat good at this, but not so much with Docker, so can you give me more details or point to how I need to update this mystery definition file you speak of?


(Kane York) #8

It’s in /var/discourse/containers/app.yml. It’s the file where you put your domain name, SMTP settings, admin email, etc.