# WP Discourse Curl 错误在引用 cacert.pem 后仍然存在

**URL:** https://meta.discourse.org/t/wp-discourse-curl-error-persists-after-cacert-pem-reference/106636
**Category:** WordPress
**Created:** [2019年一月15日 23:41 UTC](https://meta.discourse.org/t/wp-discourse-curl-error-persists-after-cacert-pem-reference/106636 "2019-01-15T23:41:58Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![scott\_moree](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/scott_moree/32/129424_2.png) [@scott\_moree](https://meta.discourse.org/u/scott_moree)
#### Post date: [2019年一月15日 23:41 UTC](https://meta.discourse.org/t/wp-discourse-curl-error-persists-after-cacert-pem-reference/106636/1 "2019-01-15T23:41:58Z")

</div>

I have a wordpress site `https://wordpress.example.com` that i am trying to get comments working with my discourse `https://discourse.example.com`. both are one click installs from digital ocean and have ssl when i first got the “curl error 60: ssl certificate problem: unable to get local issuer certificate” I updated php.ini to reference a newly downloaded cacert.pem however this has not resolved the issue for me  
any help would be greatly appreciated.

## ![image](https://global.discourse-cdn.com/meta/original/3X/2/c/2cb46e06316f08e9cac7fa88132def33497a6fb2.png)

## ![image](https://global.discourse-cdn.com/meta/original/3X/5/3/53a6032c65ba21d26f01475a1f7dde5e98b0837b.png)

## ![image](https://global.discourse-cdn.com/meta/original/3X/7/a/7aa2d6e88860bb49c3b4a3c6343963900aa81f23.png)

`array(8) { ["default_cert_file"]=&gt; string(21) "/usr/lib/ssl/cert.pem" ["default_cert_file_env"]=&gt; string(13) "SSL_CERT_FILE" ["default_cert_dir"]=&gt; string(18) "/usr/lib/ssl/certs" ["default_cert_dir_env"]=&gt; string(12) "SSL_CERT_DIR" ["default_private_dir"]=&gt; string(20) "/usr/lib/ssl/private" ["default_default_cert_area"]=&gt; string(12) "/usr/lib/ssl" ["ini_cafile"]=&gt; string(0) "" ["ini_capath"]=&gt; string(31) "/etc/php/7.0/apache2/cacert.pem" }`

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2019年一月16日 07:38 UTC](https://meta.discourse.org/t/wp-discourse-curl-error-persists-after-cacert-pem-reference/106636/2 "2019-01-16T07:38:12Z")

</div>

It doesn’t sound like a Discourse problem since there is no php with discourse.

How did you enable https on either site?

If you include your site url people could check.

---

<div class="post-metadata">

### Author: ![scott\_moree](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/scott_moree/32/129424_2.png) [@scott\_moree](https://meta.discourse.org/u/scott_moree)
#### Post date: [2019年一月16日 16:48 UTC](https://meta.discourse.org/t/wp-discourse-curl-error-persists-after-cacert-pem-reference/106636/3 "2019-01-16T16:48:47Z")

</div>

The url’s are [https://tutorials.datasciencedojo.com](https://tutorials.datasciencedojo.com) and [https://discuss.datasciencedojo.com](https://discuss.datasciencedojo.com)  
I am honestly not sure how ssl was setup i confirmed with a PM it was not setup with letsencrpyt was told it is using a wildcard

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2019年一月16日 16:52 UTC](https://meta.discourse.org/t/wp-discourse-curl-error-persists-after-cacert-pem-reference/106636/4 "2019-01-16T16:52:08Z")

</div>

It looks like a WordPress/Apache problem. I’d google for the error you mentioned above.

---

<div class="post-metadata">

### Author: ![adamprocter](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/adamprocter/32/120116_2.png) [@adamprocter](https://meta.discourse.org/u/adamprocter)
#### Post date: [2020年四月16日 11:54 UTC](https://meta.discourse.org/t/wp-discourse-curl-error-persists-after-cacert-pem-reference/106636/5 "2020-04-16T11:54:39Z")

</div>

我刚迁移了服务器，遇到了这个问题 @scott_moree 您解决了吗？如果解决了，请问是如何解决的？
