WP-Discourse display comments


(John Arce) #1

I just installed the wp-discourse plugin. but the comments thread is not displaying on my wordpress site.

Screenshot:

I want the same setup of codinghorror.

Any tips?


(Ben T) #2

I believe there is a configuration flag for the number of comments to display. Try setting it to a higher number.


(John Arce) #3

Can you check my settings?


(Ben T) #4

I don’t have a live install to check on, but you may want to set the Bypass trust level score to 0 as well if you want all comments to show up.

You can see what would be pulled by going to a topic on your discourse install, removing the traling number and replacing it with /wordpress.json?best=20. Here is this thread for example.


(John Arce) #5

I tried changing Bypass trust level score to 0 but still getting same issue.

Anyone using the wp-discourse? let me know your thoughts on this


(Jeff Atwood) #6

Did you set up the API key? It’s the 2nd setting from the top for WP-Discourse.

Get it from the /admin panel, API section.


(John Arce) #7

After I regenerate my API key then save it again. Finally it’s working.


(Rhinodf) #8

excuse my ignorance guys. The answer to this is likely to be answered somewhere else here but im having the same problem.

I have tried everything in this thread to no avail… also slightly unrelated but my header has changed since moving my installation


(Rhinodf) #9

Found the problem! Was because I didn’t choose a correlating user name in Wordpress