Wrong URL for my Discourse site?!


(Marc Andrew) #1

Hi,

I have a Discourse build at https://community.kissmyui.com/

But when you search ‘kissmyui’ in Google, the URL is shown as http://www.upbeatdxb.com/

Where has that URL (which I’ve never heard of) come from?

Thanks


(Eli the Bearded) #2

The IP addresses for the two sites differ:

;; QUESTION SECTION:
;community.kissmyui.com.                IN      A

;; ANSWER SECTION:
community.kissmyui.com. 300     IN      A       104.24.102.160
community.kissmyui.com. 300     IN      A       104.24.103.160

;; AUTHORITY SECTION:
kissmyui.com.           172459  IN      NS      jeff.ns.cloudflare.com.
kissmyui.com.           172459  IN      NS      melinda.ns.cloudflare.com.

;; QUESTION SECTION:
;www.upbeatdxb.com.             IN      A

;; ANSWER SECTION:
www.upbeatdxb.com.      13949   IN      CNAME   upbeatdxb.com.
upbeatdxb.com.          13949   IN      A       104.131.47.104

;; AUTHORITY SECTION:
upbeatdxb.com.          172349  IN      NS      ns40.arcasolutions.com.
upbeatdxb.com.          172349  IN      NS      ns50.arcasolutions.com.
upbeatdxb.com.          172349  IN      NS      ns20.arcasolutions.com.
upbeatdxb.com.          172349  IN      NS      ns30.arcasolutions.com.

Checking response headers, it looks like upbeatdxb.com is resolving to the same host that is actually hosting Discourse, and community.kissmyui.com is resolving to a Cloudflare accelerator:

http://www.upbeatdxb.com/          
HTTP/1.1 200 OK
Server: nginx
Date: Wed, 03 May 2017 21:43:20 GMT
Content-Type: text/html; charset=utf-8
Connection: close
Vary: Accept-Encoding
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
X-Discourse-Route: list/latest
Cache-Control: no-store, must-revalidate, no-cache, private
X-Request-Id: 2e991851-f575-4911-be58-61444d01adc1
X-Runtime: 0.072481
X-Discourse-TrackView: 1
X-UA-Compatible: IE=edge


http://community.kissmyui.com/
HTTP/1.1 301 Moved Permanently
Date: Wed, 03 May 2017 21:46:36 GMT
Connection: close
Set-Cookie: __cfduid=d1684e0e58d5b13cc9d375c29fbf574f41493847996; expires=Thu, 03-May-18 21:46:36 GMT; path=/; domain=.kissmyui.com; HttpOnly
Cache-Control: max-age=3600
Expires: Wed, 03 May 2017 22:46:36 GMT
Location: https://community.kissmyui.com/
Server: cloudflare-nginx
CF-RAY: 359669f7f2ed5146-SJC

(Marc Andrew) #3

Thanks for the detailed response Elijah.

So who is at fault here, so I know where to focus? DigitalOcean where it’s hosted, or CloudFlare acting as my CDN?

Many thanks


(Eli the Bearded) #4

Ultimately it’s probably wrong for upbeatdxb.com to have the IP address of your server. I’m not sure what the “Discourse” solution for this sort of problem is. In general, you can use a canonical link in html:

<link rel="canonical" href="https://community.kissmyui.com" />

Or get your web server to issue redirects for requests with the wrong hostname. The redirects would probably be my choice, but I don’t know how that would interact with Cloudflare.


(Rafael dos Santos Silva) #5

Use HTTPS. That will help.