YAML syntax error - LANG=en_US.UTF-8


(Tomo Vukasović) #1

Running latest docker installation on digital ocean. I had to change mail setup in app.yml after the change I ran:

./launcher rebuild app

The error received:

(<unknown>): found a tab character that violate intendation while scanning a plain scalar at line 67 column 13 -e LANG=en_US.UTF-8
YAML syntax error. Please check your /var/docker/containers/*.yml config files.

The site went down and it was easily fixed with:

./launcher start app

but my app.yml was not updated with new mail configuration. I have manually changed/translated some strings in serveren.yml and I am assuming this was the main problem for this error.


(Tomo Vukasović) #2

Should I follow these instructions:

Don’t want to mess something up…again. I do not care about translations.


After Configure app.yml I got this error
(Jens Maier) #3

There’s a mistake in your app.yml file. The YAML format requires that all lines are indented with plain spaces and that indentation matches YAML’s rules. The program you’ve used to edit this file has inserted a tab character, however, which YAML doesn’t permit.

Simply open your config file and make sure that line 67 contains no tabs but only spaces. If you’re using nano, remove the whitespace at the beginning of the line, then type single spaces to move the line to the proper indentation level.


After Configure app.yml I got this error
(Tomo Vukasović) #4

Thanks that worked. I don’t remember adding tab, but here we go it works again.