You were logged out when creating a topic


(Leon Tian) #1

When I create a topic ,this bug appear.

Sometimes,the refresh is not work.

Sometimes ,I am not login ,when I click a topic ,this bug also appear.

Sometimes , this bug also appear in mobile broswer,like safari

Can you help me ? what’s the reason?

My website:


#2

Pluggins? Version?

Did you tried safe mode?


(Leon Tian) #3

This is my plugins page.

The version is Discourse 2.0.0.beta5.

I have not tried safe mode , but I will try it later. :roll_eyes:


(Cameron:D) #4

Does it happen with a different browser?

I had this problem too and it turned out to be my Firefox configuration (I had privacy.firstparty.isolate enabled, which it didn’t seem to like).


#5

I’ve seen an unexpected “you were logged out” message too a couple of weeks ago. Next time it happens I’ll make a note of the circumstances / browser etc.


(Leon Tian) #6

PC:chrome , firfox
Mobile: safari

That`s the browser which has happened .

I think this is a big bug ! ! !

My server info:

CentOS Linux release 7.3.1611 (Core)
4G Memory


#7

I just had this problem, too, and it turned out to be first party isolation. So much for being “modern,” when it can’t handle such a feature. And unfortunately, it’ll probably remain a problem, since the github page doesn’t have an issue tracker. The ironic part of all of this is that I experienced this trying to use mozilla.discourse, and couldn’t log on due to an incompatibility with a Mozilla browser feature.