ActivityPub Plugin

Hard to say, as I don’t have access to the mastodon servers you tried from. But I suspect it was a HTTP signature issue. I have it on my agenda to add better logging for HTTP signature issues, which could shed more light on this. Try again on those same servers in a bit. It could have been caching issue with the failed searches you got immediately after turning off signatures.


Hum, no, still 404s.

Given that I tried with widely used public servers (one of which I had never used before and had no reason to have the account in its cache), I’d guess not being able to follow would be the most common experience, even from mastodon.

I noticed you are the admin of, it’d probably be great if you shared which, possibly non-default, settings this server has related to HTTP signatures that might be enabling interoperability, both because it helps pin point issues/current limitations and possible contribution vectors :-).

It’s a standard Mastodon server. You can possibly break things with custom settings. But if you’re running a standard mastodon server the plugin will work. The plugin works fine on many other instances. For example you can follow announcements on

Your actor is not able to be found there as you say. There’s something else going on. Are you using cloudflare perhaps? Have you made any other customisation attempts? Do you have access to your webserver (e.g. nginx) logs?

@evilham I’ve sent you a PM to debug further, so we don’t take over this topic.

1 Like

I have the same issue, I published this Typofixer per la lingua italiana - Progetti - the category is enabled for activitypub and should be
From here I see that exists

There is a way to check if effectively was published like a link?
I see that users are able to follow it but searching on mastodon I don’t find it.

I disabled the HTTP signatures and enabled the logs (both the options) but I don’t get anything in /logs about this plugin

I also published this to double-check ShareBackported estensione per Firefox - Progetti -


Thanks for the report @Mte90, I’m going to be adding some more logs to shed more light on this scenario soon. Thanks for your patience!

cc @evilham.


I am in the same case of a subcategory and have no follower. But when I try to follow I get an error:


The error does not log. Try a Follow activity from Mastodon gives a 404.

1 Like

Hey @hellekin, thanks for the report. That is perhaps a different issue. Visiting directly I am seeing some issues with it, for example

Nevertheless, please hold tight while I add some more logs for this case.

@hellekin @evilham @Mte90 Thanks for your patience! I’ve raised a PR to log all of the incoming request errors this plugin sends back for a failed request from an external actor.

When this PR is merged, please update your plugin, and then if you could:

  1. ensure that verbose logging is enabled (site setting “activity pub verbose logging”); and

  2. attempt exactly the same action you attempted previously.

Please also keep in mind a few things:

  1. There are already over 26 different incoming request error scenarios. While it may seem superficially similar, your issue may not be the same as that experienced by other folks, so specificity is key here, i.e. the specific steps you took.

  2. The specific error messages are already being returned on failed requests to the actor that attempted the request, so if you have access to them, you may also want to check the logs of the actor you’re trying to connect to Discourse.

I’m keen to hear how you go, and to investigate each of your cases further. Thanks again!


I had that issue too, maybe more information about why is not valid can help.

Waiting so I can do more tests :slight_smile:


Thanks Angus, this PR is now merged.


I love the fact we can now share topics with other Discourse instances!


Hey @Lhc_fl sorry for the delay in getting to this, but could you elaborate a bit with what you mean here? Perhaps with an example?

1 Like

I haven’t tried this in a while, but the last time I tried it, if my username contains non-latin characters (e.g. @零卡), my posts will not be viewable on Mastodon.

But except for some problems with my current Discourse site (and also my life), I can no longer test it.

1 Like

Ah, I see.

It seems Mastodon does not support non-latin characters in usernames.

There may need to be a conversion to latin characters for the username of your ActivityPub Actor. I’m taking a look at this.


This will be addressed when this is merged

Usernames that won’t work in the Fediverse (i.e. non ASCII) will be automatically converted into a compliant variant of their username, for the User’s Actor’s username (their Discourse username will remain untouched). I will also probably be adding the ability for users to change their ActivityPub username (so you’re not just stuck with a automatically converted ActivityPub username if your Discourse username is non ASCII).


Would it be possible to add a class to the body when you are navigating to a category with ActivityPub enabled?

The markup for the topic-list of the activity pub view is slightly different from other core pages in Discourse, causing some themes to not style this page correctly.

An example of which can be seen here on meta when using the meta-branded theme and visiting → Discourse Meta

Normally, the top nav area is wrapped in list-controls

And under it is wrapped in list-container


Yeah, we should do something in the plugin to fix this. I’ll take a look. Thanks!



I’m trying out the plugin and I’ve noticed an issue where the [note][/note] tags are being ignored and everything is being published.

I’ve looked around the options but I didn’t see anything obvious explaining this.

ActivityPub type to publish posts in this category as : Note
ActivityPub publication type : First Post

Am I missing something or are others encountering this ?

1 Like

Hey @gde,

Was this always set to Note? Did you previously have it set to Article?

Hi @angus ,

yeah, the main goal was never to have articles published, so I never set it to Article