Another : failed upgrade from 3.1.0 to 3.2.0 beta 4

AI-generated summary

The discussion revolves around a failed upgrade from Discourse 3.1.0 to 3.2.0 beta 4. jhf2442 encountered issues and found that the problem was caused by the discourse-sidebar-categories plugin, which led to a blank master page. They also disabled the discourse-email-all plugin as a precaution.

jhf2442 provided logs showing warnings during the build process, including unmet peer dependencies and incorrect peer dependencies for various packages. Firepup650 responded that these warnings are normal and can be safely ignored, citing similar warnings on every rebuild.

First I also ran into some strange build issues, whihc solved when I issued a gut pull first to bring the launcher up to date :roll_eyes:

While building the app, yarn throws some warnings - could any dev comment on this ?

I, [2024-01-01T14:41:28.030095 #1]  INFO -- : > cd /var/www/discourse && su discourse -c 'yarn install --frozen-lockfile && yarn cache clean'
warning Resolution field "unset-value@2.0.1" is incompatible with requested version "unset-value@^1.0.0"
warning Pattern ["wrap-ansi@^7.0.0"] is trying to unpack in the same destination "/home/discourse/.cache/yarn/v6/npm-wrap-ansi-cjs-7.0.0-67e145cff510a6a6984bdf1152911d69d2eb9e43-integrity/node_modules/wrap-ansi-
cjs" as pattern ["wrap-ansi-cjs@npm:wrap-ansi@^7.0.0"]. This could result in non-deterministic behavior, skipping.
warning " > discourse-markdown-it@1.0.0" has unmet peer dependency "xss@*".
warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @ember/legacy-built-in-components@0.5.0" has incorrect peer dependency "ember-source@>= 4.8".
warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @uppy/aws-s3@3.0.6" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @uppy/aws-s3-multipart@3.1.3" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @uppy/xhr-upload@3.1.1" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse-plugins > ember-this-fallback@0.4.0" has unmet peer dependency "ember-source@^3.28.11 || ^4.0.0".
warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @uppy/aws-s3 > @uppy/xhr-upload@3.3.0" has incorrect peer dependency "@uppy/core@^3.2.1".
I, [2024-01-01T14:42:26.369845 #1]  INFO -- : yarn install v1.22.19
[1/5] Validating package.json...
[2/5] Resolving packages...       
success Already up-to-date.
$ yarn --cwd app/assets/javascripts $(node -e 'const argv = JSON.parse(process.env.npm_config_argv).original; const passthrough = [`--frozen-lockfile`, `-s`].filter(arg => argv.includes(arg)); console.log(passth
rough.join(` `));')   
yarn install v1.22.19     
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...

in the end, it turned out to be the git clone GitHub - Toxuru/discourse-sidebar-categories · GitHub plugin that caused issues, leading to a blank master page, whereas direct access to individual posts was still possible. Found out using try and error (i.e. disabling all plugins, recompiling the image and and re-enabling the plugin one after the other

Also found this one in the logs - it’s git clone GitHub - mozilla/discourse-email-all: Allow an admin to email everybody · GitHub that I’ve also disable to be on the safe side for now

==> unicorn.stderr.log <==
I, [2024-01-01T15:00:30.194986 #85]  INFO -- : Refreshing Gem list
Plugin name is 'email-all', but plugin directory is named 'discourse-email-all'

Hope this helps some other admins that run into similar trouble

Hope this helps

That should be fine, IIRC, the official topic-voting plugin raises the same kind of warning.

Those are also normal, we have the same type of warnings on every rebuild and it’s fine.