Hello,
I tried to do the solution by this My discourse forum crashed after upgrade to 3.5.0.beta8
but it does not works
I am using Ubuntu 24.04.3 LTS, any one can help me?
A user encountered an issue rebuilding their Discourse app due to a Docker daemon API version mismatch (1.43 required 1.44). They tried a solution from a previous thread but it didn’t work. The error messages indicated missing Nginx outlets in the configuration. Steven suggested updating Docker using a specific command. After updating Docker and enabling the service, the site worked, but the user still saw warnings about missing Nginx outlets. Yt.w shared their solution involving manually adding Docker’s official repository for Ubuntu 24.04.3 LTS, upgrading Docker, and then rebuilding the app.
Hello,
I tried to do the solution by this My discourse forum crashed after upgrade to 3.5.0.beta8
but it does not works
I am using Ubuntu 24.04.3 LTS, any one can help me?
the error is
'I, [2025-09-13T18:37:08.577996 #1] INFO -- : > grep -q 'outlets/before-server' /etc/nginx/conf.d/discourse.conf || ( >&2 echo 'The "before-server" Nginx outlet is missing. This version of discourse_docker is not compatible with the chosen Discourse version.' ; exit 1 )
I, [2025-09-13T18:37:08.581833 #1] INFO -- :
I, [2025-09-13T18:37:08.581913 #1] INFO -- : > grep -q 'outlets/server' /etc/nginx/conf.d/discourse.conf || ( >&2 echo 'The "server" Nginx outlet is missing. This version of discourse_docker is not compatible with the chosen Discourse version.' ; exit 1 )
I, [2025-09-13T18:37:08.585915 #1] INFO -- :
I, [2025-09-13T18:37:08.585994 #1] INFO -- : > grep -q 'outlets/discourse' /etc/nginx/conf.d/discourse.conf || ( >&2 echo 'The "discourse" Nginx outlet is missing. This version of discourse_docker is not compatible with the chosen Discourse version.' ; exit 1 )'
docker: "specify mac-address per network" requires API version 1.44, but the Docker daemon API version is 1.43.
you can try updating Docker using this command:
wget -qO- https://get.docker.com/ | sh
Thank you so much
after I did
systemctl enable --now docker
my site works,
but log still show me
I, [2025-09-13T19:00:59.928538 #1] INFO -- : > grep -q 'outlets/before-server' /etc/nginx/conf.d/discourse.conf || ( >&2 echo 'The "before-server" Nginx outlet is missing. This version of discourse_docker is not compatible with the chosen Discourse version.' ; exit 1 )
I, [2025-09-13T19:00:59.932337 #1] INFO -- :
I, [2025-09-13T19:00:59.932412 #1] INFO -- : > grep -q 'outlets/server' /etc/nginx/conf.d/discourse.conf || ( >&2 echo 'The "server" Nginx outlet is missing. This version of discourse_docker is not compatible with the chosen Discourse version.' ; exit 1 )
I, [2025-09-13T19:00:59.936410 #1] INFO -- :
I, [2025-09-13T19:00:59.936477 #1] INFO -- : > grep -q 'outlets/discourse' /etc/nginx/conf.d/discourse.conf || ( >&2 echo 'The "discourse" Nginx outlet is missing. This version of discourse_docker is not compatible with the chosen Discourse version.' ; exit 1 )
any side effects?
Let me share my solution
The problem is that Docker 28.x is not available in Ubuntu 24.04.3 LTS’s official package list.
cd /var/discourse
git pull origin main --autostash
sudo install -m 0755 -d /etc/apt/keyrings
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | \
sudo gpg --dearmor -o /etc/apt/keyrings/docker.gpg
echo \
"deb [arch=$(dpkg --print-architecture) signed-by=/etc/apt/keyrings/docker.gpg] \
https://download.docker.com/linux/ubuntu noble stable" | \
sudo tee /etc/apt/sources.list.d/docker.list > /dev/null
apt upgrade docker-ce
systemctl enable --now docker
./launcher rebuild app