Cannot signup with google?

Just bought the standard package and setup my website. I followed the tutorial and setup google signup. But when I click on the with google button, it showed this page:

400: Error: redirect_uri_mismatch

The redirect URI in the request, xxx/auth/google_oauth2/callback, does not match the ones authorized for the OAuth client. To update the authorized redirect URIs, visit:

What’s going on? How do I fix it?

I have seen that error message when the URL that has been added to the ‘Authorized Redirect URI’ section on Google is incorrect. It should be set to

Replace with your site’s domain.


That’s exactly what I added in google.

Did you enable Google logins on your Discourse site? It’s in step 9 of Configuring Google login for Discourse. Try going through that guide again and make sure everything has been setup correctly.

It almost certainly isn’t. Make sure that it’s https. Trailing slash or space could also be a problem.

1 Like

Oh, somehow the field was cleared. Thanks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.