Discourse Activitypub 재구축 후 502 오류 발생

셀프 호스팅 2컨테이너 환경에서 오늘(최신 버전) 재빌드한 후 Activitypub에서 502 오류가 발생합니다. web_only.yml에서 해당 부분을 주석 처리하면 문제가 해결됩니다.

1개의 좋아요

확인해 드립니다. 이 기능도 비활성화해야 했습니다.

1개의 좋아요

최근에 수정된 것 같습니다: https://github.com/discourse/discourse-activity-pull/340. 현재 사용 중인 Discourse 코어 버전이 Rails 8.1을 포함하는지 아닌지 알고 계신가요? @techAPJ 이 변경 사항에 대해 호환성 항목을 추가해야 할 수도 있습니다.

2개의 좋아요

그렇게 생각됩니다:

root@foorumi-hel-web-only:/var/www/discourse# bundle exec rails --version
Rails 8.1.3.1
2개의 좋아요

@pmusaraj Rails 8.0.5.1과 8.1.3.1에서 이 문제를 확인했습니다. 호환성 항목은 필요하지 않아야 합니다: 수정된 association은 두 버전 모두에서 정상적으로 작동합니다. 이전 선언은 polymorphic: true와 함께 class_name을 지정하고 있어 Rails 8.1에서 로딩에 실패합니다.

최초 보고서는 수정이 병합되기 약 15분 전에 게시되었으므로, 수정 사항이 적용되지 않은 재빌드에서 발생한 것일 수 있습니다.

@Jagster @satonotdead ActivityPub를 활성화한 상태로 다시 재빌드해 볼 수 있을까요? 여전히 502 오류가 발생한다면 /logs의 에러 로그를 공유해 주십시오.

2개의 좋아요

재구성이 잘 작동했습니다!

2개의 좋아요