"Ensure ad-blockers are disabled and try reloading the page." when enabling Data Explorer

I’d done that. I’ve just now tried new user account + clean Firefox and I get the same thing.

Rails log at the moment enable for the plugin got flipped:

Started POST "/presence/update" for at 2023-09-21 18:20:19 +0200
Processing by PresenceController#update as */*
  Parameters: {"client_id"=>"361de32163a941b09d6b822826359a04", "present_channels"=>["/chat-user/core/2"]}
Completed 200 OK in 9ms (Views: 0.2ms | ActiveRecord: 0.0ms | Allocations: 1697)
Started PUT "/admin/site_settings/data_explorer_enabled" for at 2023-09-21 18:20:20 +0200
Processing by Admin::SiteSettingsController#update as */*
  Parameters: {"data_explorer_enabled"=>"true", "id"=>"data_explorer_enabled"}
  Rendered text template (Duration: 0.0ms | Allocations: 1)
Completed 200 OK in 51ms (Views: 1.8ms | ActiveRecord: 0.0ms | Allocations: 9266)
Started POST "/presence/update" for at 2023-09-21 18:20:20 +0200
Processing by PresenceController#update as */*
  Parameters: {"client_id"=>"361de32163a941b09d6b822826359a04", "present_channels"=>["/chat-user/core/2"]}
Completed 200 OK in 7ms (Views: 0.1ms | ActiveRecord: 0.0ms | Allocations: 1904)
1 Like

Trying to enable the plugin:

`Unable to configure link to '[en.explorer.title]'. Ensure ad-blockers are disabled and try reloading the page.

1 Like

I can reproduce that on my production Discourse site with the Chrome browser on Ubuntu. It is kind of surprising to see that notice:

Note that the Data Explorer plugin actually appears as being enabled, even though the notice is shown.

Interestingly, it doesn’t seem to prevent the Data Explorer plugin from being enabled or used. What I’m finding is that if I refresh the page, the Data Explorer entry shows up in the plugin’s list:

Testing this some more, I’m finding the same behavior with any plugins that add a new plugin page. For example the Calendar and Gamification plugins. Maybe it’s something related to Discourse’s attempt to dynamically load the /admins/plugin page to add the new plugin entry that’s triggering the notice.

Note, if you’re testing this by toggling plugins off and on with an ad-blocker enabled, you need to fully refresh the page after disabling the plugin to get the notice after re-enabling a plugin.

I get what jokingly I called “blue screen” - I get Oops after refreshing the page, I started a tread in support but got little luck there and so I came here.
I only can bring the site back to normal by safe-mode and then disabling the plugin. I reproduce that with fresh, clean browser(s) with no extensions, no ad-blockers, a no other plugins neither.

Are you finding this on a production site?

If the issue is only happening on a local development site, there are a number of other things that could be causing it.

I’m not sure what you mean by ‘production’. I do deploy as official howto instructs. Not on in the cloud, if that what you mean by local.

By production I mean that the site is not a local development site. The reason I’m asking is because sometimes issues occur on local development sites that do not occur in production. For that reason, I am careful about reporting issues that I have only reproduced on my local dev site. When I do that, I always state that I have only reproduced the issue on my dev site.

I learned this the hard way :slight_smile: I think that post has been deleted now.

I can repro this on my test site (which is production). I think it’s mainly a UI thing as the ‘warning’ is actually telling you you need to refresh the page to load in the new tab. The red makes it seem more intense though. :slight_smile:

It does seem like there may be a missing translation as well.

Let’s merge these into it so we’re not cross-posting the issue in multiple places. :+1:

This I can’t replicate. When I refresh the page the warning goes away, and the data explorer tab is now on-screen.

1 Like

@simon This is weird nomenclature you have there, this is new to me.
production VS lab/devel is what I’m used to, with former having a real customers/users and the later being a test/lab env for devel (but not exclusively) — locality or location of it had no part in the equation, very local, remote or cloud played no role in nomenclature I know.
Again, I deploy following official guide(not for a developer one), it should be easy to reproduce, it reproduces for me every time.

1 Like

I think we are talking about different things. I was wondering if you were only finding the issue on a development site that you have installed on your computer. It sounds like that is not the case.

Note that both JammyDodger and I have reported that we can reproduce most of what you are reporting. My concern was this:

If that is happening on a production site it is a problem that needs to be dealt with.

(related?) Can a plugin be en/dis-abled within rails console?

I’ve just tried with a second plugin – discourse-automation – so have two. When I flipped that one on (data-explorer remains off) now even safe-mode will not do. Opps all the way.

This is sounding like an issue with your setup @lejeczek. Does it do a similar thing when you install a plugin that doesn’t need an extra tab? (eg. spoiler).

But you can disable plugins using the rails console:

SiteSetting.discourse_automation_enabled = false

SiteSetting.data_explorer_enabled = false

spoiler-alert does not give that warning, but it results in Opps as well, when page reloaded.

Is this on a development install on your own computer, or a standard install on a VPS?

Do you have anything in your /logs page that would give any extra detail?

It is an install following official guide, on bare-metal, not in a cloud/vps.

I cannot reproduce this. I just installed all of these on a freshly updated Discourse 3.2.0.beta2-dev without a problem. Data Explorer was the first one I installed.

I don’t know what else to say, as to what happens I have nothing else to add.
I presume that since plugin installs that means - installation/deployment of Discourse/container works a ok.
It reproduces every time — everything else, rest of Discourse also seems to work without problems.

As for everything else? I have no idea what ad-bloker means in this context & for Discourse in its entirety, what the code does – thus am unable to debug, work around it.
As I explained I tested with & without the only ad-blocker I use. I also assume that the issue(the code) has nothing to do with something/anything outside the web browser, with things such as OS / network / organisation(when one like me, is a part of one).

are you seeing anything in admin - logs - error logs?

did you try restarting your Discourse server?

That I’ve done number of times, os, docker.

Trying different plugin, which too results in Opps
Back-trace logs show:

Message (6 copies reported)

ActionView::Template::Error (The asset "plugins/discourse-spoiler-alert.js" is not present in the asset pipeline.
app/helpers/application_helper.rb:93:in `script_asset_path'
app/helpers/application_helper.rb:146:in `block in preload_script'
app/helpers/application_helper.rb:145:in `map'
app/helpers/application_helper.rb:145:in `preload_script'
app/views/layouts/application.html.erb:41:in `each'
lib/topic_list_responder.rb:15:in `block (2 levels) in respond_with_list'
lib/topic_list_responder.rb:8:in `respond_with_list'
app/controllers/list_controller.rb:110:in `block (2 levels) in <class:ListController>'
app/controllers/application_controller.rb:421:in `block in with_resolved_locale'
app/controllers/application_controller.rb:421:in `with_resolved_locale'
lib/middleware/omniauth_bypass_middleware.rb:74:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
lib/middleware/anonymous_cache.rb:389:in `call'
lib/middleware/gtm_script_nonce_injector.rb:10:in `call'
config/initializers/100-quiet_logger.rb:20:in `call'
config/initializers/100-silence_logger.rb:29:in `call'
lib/middleware/enforce_hostname.rb:24:in `call'
lib/middleware/request_tracker.rb:233:in `call'


sprockets-rails (3.4.2) lib/sprockets/rails/helper.rb:84:in `compute_asset_path'
actionview (7.0.7) lib/action_view/helpers/asset_url_helper.rb:203:in `asset_path'
app/helpers/application_helper.rb:93:in `script_asset_path'
app/helpers/application_helper.rb:146:in `block in preload_script'
app/helpers/application_helper.rb:145:in `map'
app/helpers/application_helper.rb:145:in `preload_script'
app/views/layouts/application.html.erb:41:in `each'
actionview (7.0.7) lib/action_view/base.rb:244:in `public_send'


HTTP HOSTS: discourse.test.web

I remember having come across this issue with Data Explorer. I’m not sure at all about a standard, production install, but I definitely saw it on a dev install.

1 Like