Isso é estranho, a VM em que está rodando tem 3,7 GB de RAM disponível.
Acabei de fazer uma reconstrução monitorando o uso de RAM e, claro, passou (depois de falhar 3 dias seguidos, mais de 5 vezes). Adicionarei um pouco de swap, mas seria interessante saber o que adicionou o uso extra de RAM no processo de construção.