Events Plugin 📆

Hey @csmu, does this one help?

2 Likes

Adding &api_key={valid-api-key}&api_user={valid-api-user} to the webcal url worked.

4 Likes

Hi, @DavidO
I’ve fixed this issue. You’ll need to update the plugin and your discourse to the master or tests-passed branch of discourse to use this fix.

Let us know if it works fine for you.

2 Likes

I’ve just updated to that latest version of discourse

2.4.0.beta2

with database schema v20190812141433.

and locations and events are no longer showing in the user interface.

Anyone else here having the same issues?

2 Likes

@csmu I’ve been running the same version on my dev instance without these issues.
What are the recent changes you’ve done other than updating the instance?

@angus, what might be going on here?

Hey @csmu, could you fill out a bug report here? https://thepavilion.io/w/bug-report.

In particular we need:

  1. Links to your instance / topics where this is happening
  2. Any server or client-side logs you can provide

Which the wizard will ask for.

@fzngagan and I will follow up on that report.

2 Likes

I can confirm I run into the same issue. I am not able to create new Events. I’m on version v2.4.0.beta2 +328 and the latest Events Plugin Version.

Edit:
Old Events are visible and can be edited. The Agenda is also missing in the category overviews.

If I can provide you some data just ask me for what I have to look :eyes:

3 Likes

Can you create a bug report here: Bug Report. I and @angus will follow up there. We’ll keep you updated on the issue.

I’m trying to reproduce the issue on a production site I’m running.

Update

I’ve confirmed the issue. I’ll start looking into it tomorrow.

I’ve already created an issue here: Add Date/Time button missing on latest discourse - Bug Reports - Pavilion

All the updates about the debugging and resolution of the issue will be posted there.

3 Likes

The site is by invitation only. Please send preferred email addresses for the invitations via private message.

Any tips on what to look for … how to find the client side logs … what to look for in the server side logs … do I have to enter the container to get the logs?

This commit resolves all of the above issues.

Update the plugin to the latest version to resolve the issues.
Thanks @csmu for the initial report.

5 Likes

Events are now working for us on our staging and production servers … thanks :+1:

3 Likes

Thats really good to know.

1 Like

Cheers, Am I slow? :slight_smile: I’m not able to figure out how to make the Agenda and Calendar views appear.

Plugin is installed all right. A bunch of checkmarks have been checked:

Category settings have been set:

But still, no event list. And no Add Date and Time button.

Am I missing something?

Are you on the latest version of discourse and the plugin?

Yup, think so.

image

Just installed plugin today and think Discourse got updated as well.

1 Like

I’ll check this on my instance and get back to you.

1 Like

I cannot reproduce the issue. I installed the plugin fresh on my site and it works.
Can you go to /admin/upgrade on your site and see if everything is upto date. Mine shows +393.

Ok. Did the upgrade but still nothing. And the error logs show nothing. Weird. I must have missed a setting somewhere?

Can you do ‘ctrl+shift+R’ to hard reload your page. Also, have you selected the correct category in composer?

Did that. Tried in another browser as well.

Am I on the latest plugin version?

image

0.1 doesn’t sound like latest. Maybe I used the wrong git url when installing?

https://github.com/paviliondev/discourse-events.git

Edit: I have the latest version. 87292d7.

1 Like