How can I set s3_force_path to true?

Please help me!!!
How can I set s3_force_path to true to make my object storage server work?

1 Like

There is no such setting. There used to be a s3_force_path_style setting, but it was removed in 2019.

Perhaps you can say what problem you are trying to solve. What object storage server are you trying to use? Have you looked at Using Object Storage for Uploads (S3 & Clones)?


Thank Jay for your replay.

I’m using company privacy object storage server. It’s compatible with AWS S3 protocol but path style is virtual-host-style.

Did they develop this software on house or is it minio? Something else? There are instructions for minio on the page I linked earlier.

It’s not Minio. AWS S3 compatible but private implementation. Using virtual-host-style :sob:

1 Like

You may be out of luck, but what if you put the bucket url as the endpoint and something else as the bucket name. Would that let it work and just store stuff in a subdirectory of the bucket?

1 Like

let me have a try.

Thanks Jay.


There may be a confusion here, since Discourse does support virtual-host style. What we do not support is path-style, and we have no plan of re-adding support for that.

1 Like

to my understanding, Discourse is based on AWS S3 SDK. Discourse can support virtual-host-style because AWS S3 SDK supports it. Is that correct?

I don’t follow. Discourse already supports virtual-host-style. It’s the only one we support for object storage.

I mean Discourse should already support virtual-host-style. Do we need setting force_path = true to enable it?

Discourse supports virtual host style.

Discourse does not supports path style.

Discourse will not add support for path style since it’s on the deprecation lost on AWS S3.

1 Like

Thank Falco. I think I misunderstood the style. My object storage supports path style only :sob:

1 Like

That’s a shame since every modern object storage service supports virtual host style, like Google, AWS, Digital Ocean, Vultr, MinIO, Backblaze, etc…

1 Like