The user derak encountered an “Unsupported Version Error” after updating Docker via the Discourse admin interface, which only updated Discourse_docker, not Docker itself. pfaffman clarified that Docker needed to be updated separately using apt install docker-ce. derak resolved the issue by following a detailed guide from ChatGPT, which involved updating the OS, uninstalling old Docker versions, adding Docker’s official repository, and installing the latest Docker version. After the update, Docker was restarted, and the Discourse update command ./launcher rebuild app worked successfully. BrianC humorously noted the solution’s reliance on ChatGPT.
Hi, I updated Docker through the “Upgrade” section. After that, I tried to update Discourse via the terminal (I use DigitalOcean’s Droplet Console). However, when running the command ./launcher rebuild app, I get this error:
ERROR: Docker version 19.03.13 not supported, please upgrade to at least 20.10.0, or recommended 24.0.7.
But I had already done the update through the “Upgrade” admin interface on the website. Now nothing is working anymore. What could have gone wrong?