我在执行每月的 Discourse 维护和更新时,注意到重建过程中出现以下错误:
I, [2025-03-22T15:54:02.806441 #1] INFO -- : > cd /var/www/discourse && sudo -E -u discourse bundle exec rake s3:upload_assets
`/root` is not writable.
和
I, [2025-03-22T15:54:12.239681 #1] INFO -- : > cd /var/www/discourse && sudo -E -u discourse bundle exec rake s3:expire_missing_assets
`/root` is not writable.
重建后:
- 我能够创建帖子,并且新图片可以毫无问题地上传到 S3。
- 我能够进入应用程序并毫无问题地运行 rake 命令。
有什么想法或建议吗?
所有操作都是在"root"用户下使用相同的会话尝试的。
这就是我发帖提问的原因。以前有过多次重建,但从未发生过这种情况。
对我来说,问题是 db:migrate 无法正常运行。
尝试了不同的后端服务器,但都收到相同的错误消息。
我最初认为这是因为 postgres 不支持 16 或 17,所以我尝试使用以下钩子运行。
仍然没有任何效果。
hooks:
after_code:
- exec:
cd: /var/www/discourse
cmd:
- export HOME=/var/www/discourse
- export BUNDLE_USER_HOME=/var/www/discourse/.bundle
- apt-get update
- apt-get remove -y postgresql-client-15
- apt-get install -y postgresql-client-16
移除了几乎所有额外的 app.yml 项目后,我遇到了一个归因于 PG vector 的错误。
安装 postgre vector 扩展后,构建过程成功完成,尽管我仍然看到“/root 不可写”。