Redirect_uri query parameter is not adding https

redirect_uri query parameter is not adding https


Note: My oidc client is already configured with

Even when we set bnconfig to it is not adding redirect url instead it is making http://https// (Please notice no colon( : ) after https) which is totally wrong. By the way if we are skipping the protocol in bnconfig command it is making http redirect url to http which is not secure.

Make sure to enable ‘force https’ site setting in your admin panel.

1 Like
  1. Enabled force_https true in admin panel.
  2. Navigated to

Now, If you observe above screenshot carefully started with https, it got redirected to http.

After the authentication is completed and gets the final redirection, below is the screenshot.

If I disable force_https then the redirection is ending up on http even when started with https.

Is your discourse site behind a proxy? If so, you will need to set the x-forwarded-proto header. This topic has more information on configuring a reverse proxy:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.