Set up Mattermost notifications using the discourse-chat-integration plugin

Hi @nommaz - sorry about that. It was indeed trying to load an image from the URL of the post, which clearly isn’t going to work :wink:

I’ve fixed it now, so if you update to the latest version of the plugin it should work as intended :slight_smile:

https://github.com/discourse/discourse-chat-integration/commit/438a9d92fe6be632b825238ce703a03dd20d285b

2 Likes

Hi David didnt work unfortunately

Are you sure it is not an issue with mattermost_provider.rb:68 ?

Thanks

Vedat

Oops, I made the change in the slack provider instead of mattermost :facepalm:

Just added another commit to correct the error, so please can you give it another try :slight_smile:

1 Like

Thanks! All set now :slight_smile:

What’s up if I get a 422 error when trying (test) to hook to Mattermost?

Make sure you copied the webhook URL correctly, and that there are no spaces before/after the URL. Is your mattermost server accessible to the internet? Or just an internal network?

3 Likes

What’s the best way to handle multiple teams / multiple mattermost servers?

I have chat integration with mattermost enabled - i subscribed to all “top level” categories that are displayed via the “/discourse watch” command but posts to “sub categories” are not caught.

Take this post: This is a test topic in the sdks category - sdk-c - openziti

it is relayed to slack properly - but it is NOT relayed to mattermost. Slack is able to subscribe to “all categories”. Mattermost does not seem to be able to.

I’ve tried all the syntax I can think of but I’ve not had luck. Any tips??

Thanks in advance…

1 Like

@david - sorry for the mention but I’m missing discourse posts in my chat integration. any chance you’re still watching this thread?

At the moment, sub-categories are not automatically included when you “watch” a category. You’ll need to either add every individual subcategory, or use the “all categories” option.

1 Like

Hey, thanks for replying!!! that’d be sweet if I could figure out ‘how’. The only categories that the plugin seems to recognize are the topmost categories?

I found/tried the “all categories” option but that also doesn’t seem to work? Man I’d really love to just use “all”, that’d be IDEAL… Am i “doing it wrong”? See screen cap below

Hi @david… the problem with the above is i cannot figure out how to sub to a “subcategory” nor does there seem to be an “all” i can use? I’d love to get this figured out.

Thanks!

1 Like

Sorry for the delayed response @Clint_Dovholuk!

Using slash commands, I think you can watch all categories like this:

/discourse watch

But the easiest way to configure notification rules is from the Discourse admin panel. There, all the options are clearly displayed in the UI, so there’s no need to try and work out the precise ‘slash command’ syntax. Check out the ‘configuring rules’ section of the plugin’s documentation for more info.

2 Likes

Thanks @david .

I posted a screen cap from the slash command before. reposting it here… you can see the ‘sub categories’ are not listed a post or two above…

I had tried the admin page before but it would immediately close the dropdown when I used it… However pressing the ‘down arrow’ seemed to jar whatever I needed loose.

I would REALLY like an ‘all’ option. Is this a plugin I can somehow edit/fix??? Right now it looks like this :confused:

To get notifications of all topics, I’d suggest deleting all of those category-specific rules, and then adding a single ‘all categories’ rule.

Can you share some more detail on what you’re seeing here? Some screenshots or a video would be great!

When editing a ‘rule’, you should be able to use the category dropdown to choose ‘(no category)’.

Once saved, it should look like this:

(‘no category’ in the dropdown is clearly a bad description of what it actually means. I’ll get that fixed up)

I think subcategories are ommitted from the help text for space. But you can still subscribe to categories by using their ‘slug’ (the name of the subcategory from the URL). So in the case of #howto:admins here on Meta, it would be /discourse watch admins.

@david here’s a video… mattermost discourse trama - YouTube Discourse told me i could send you a DM - and since it’s a video of my admin page i figured I’d try that… then it told me ‘access denied’ so here it is in public…

Thanks… I WAS able to sub categories using the slug using the slash command! I am sure I tried that… Or so I thought… but great, that worked…

I’d still like to have ALL the categories with one rule though. Would you give the video a watch and lemme know where i am failing?

Thanks

EDIT: I see now why my rules were ‘missing’ (in the video) it’s because it was unclear in the page i was on slack/mattermost setttings (which are at the top that page)
image

1 Like

@david sorry for the bump but… well… not sorry? :confused: thanks

1 Like

Sorry for the delay @Clint_Dovholuk, and thanks for posting the video!

In terms of the Slack/Mattermost confusion - if you disable the 'chat integration slack enabled` setting in the admin panel, then the Slack tab should disappear, leaving just “Mattermost”.

There is a UX issue here on our side. The option labelled ‘(no categories)’ is what you need. But clearly that is an awful label name, and we need to get that fixed up.

In terms of the slash commands, were you able to give this a try?:

(i.e. omitting a category name completely)

1 Like

if you disable the 'chat integration slack enabled` setting in the admin panel, then the Slack tab should disappear, leaving just “Mattermost”.

yep. i’d already done that :slight_smile: and since i can only upload ONE image (which is lame) i’ve had to screen cap the rest of my response (see below - this used to be three images but i’m only allowed to post one)

Solved! Thanks so much

proof my ONE rule works! yay!

2 Likes