Hi thanks, yea I managed to solve the PEM_red… error above by reverting “grey clouds”, I found your advice in another topic. Thanks! 
When I ran the wizard I just input the www. domain, maybe it’s wrong to do that? This was to get around the rate limit. Which it seems to have done, and then we get past that error onto this:
fail: nginx: runsv not running
[Wed Sep .... UTC 2026] Reload error for :
C=US, O=Let's Encrypt, CN=YR1
error 2 at 1 depth lookup: unable to get issuer certificate
error fullchain.cer: verification failed
C=US, O=Let's Encrypt, CN=YE2
error 2 at 1 depth lookup: unable to get issuer certificate
error fullchain.cer: verification failed
However that looks like a mild error as there are a run of cert success outputs in the log that simply were not happening before I grey clouded
Also ports 80 & 443 are showing open
AND (Let me add more context), the instance is resolving to the domain and allowing log-in, so the login screen appears (set to login only) and will accept credentials and two factor, then once that is successful it’s back to the “Oops…” screen of “oh not again”, even with this “mild error”
Which means I am back to where I started.
Originalyl nothing on the original server instance had been changed.
Then out of the blue, there were a few days of non performant behaviour, during this metrics were showing a weird cyclic server load beyond normal levels. Like it was reving but going nowhere. Until it finally tanked into a state of permanent “Oops”
So I started working on it. One solution was to backup and restore to a fresh discourse, which is where I have things, i.e. able to log in but back to “Oops”
I thought running latest and the postgres update would lick some bugs and what not.
I’m also seeing this printed multiple times at the end of the logs:
X-Accel-Mapping header missing
Bottom line is a bunch of problems I solved I think had nothing to do with the original issue causing the Oops screen, and I learned all about the letsencrypt rate limit which I’d never encountered 97 days yikes!), and perhaps when the server was having issues it triggered the rate limit, but this is all supposition.
So I dunno what to try next to diagnose the Oops issue.