PostgreSQL 15 업데이트

업그레이드 중 다음 오류가 발생했습니다.

Stopping PostgreSQL 15 database server: mainError: Config owner (postgres:101) and data owner (runit-log:999) do not match, and config owner is not root … failed!
failed!
could not open version file “/shared/postgres_data/PG_VERSION”: Permission denied
Failure, exiting

다음 명령으로 해결되었습니다.

sudo ./launcher enter app

그리고

chown -R postgres:postgres /shared/postgres_data
chown -R postgres:postgres /shared/postgres_run
chmod -R 700 /shared/postgres_data

3개의 좋아요