404 in admin when enabling must_approve_users


(Ryan Platte) #1

I installed Discourse following the Docker+DO instructions to the letter. Most everything is working perfectly, except the settings.

I am trying to enable the must_approve_users setting, but it fails, saying “Sorry, an error has occurred.” My web inspector and my nginx server logs both show PUT /admin/site_settings/must_approve_users requests being sent and getting 404 responses.

This seems like a bug. Is it a known bug? a regression? Is there a workaround?

Way less importantly, several of the settings have failed to save on the first try, throwing an error until I press the confirm button again once or more (I haven’t looked into why because I have a workaround). But the must_approve_users setting doesn’t ever succeed. I mention this other issue in case it’s relevant context.


(Ryan Platte) #2

Apparently there was a goof with my login session. Taking another action, I got prompted to log in again, then the setting change worked.


(Jeff Atwood) #3