500 internal server error at first page call in the morning


(Christoph) #1

Earlier this morning I accessed the admin panel of my forum via my smartphone, I incorporated discobot to change its name and then logged out. This may or may not be related to the following errors which I saw when I woke up my office PC from hibernation and did the following:

  • navigated to the browser tab with a (private) forum discussion that was still open from last night,
  • clicked on the Admin item in the hamburger menu,
  • received the standard discourse “Ooops, this message is private or deleted” (or so)
  • reloaded the browser page

After that, I first received a simple plain-text 500 internal server error. Reloading the page again didn’t help so I think the next I tried was /admin which didn’t lead anywhere (not sure what exactly the server response was). Last, I tried /login which gave me this basic login screen (plus an oversized logo of my site due to lack of CSS):

I was then able to login using that login-button and the page rendered fine.

In the error logs I find three instances of the following error (can send backtrace details for each of them if required):

ActionView::Template::Error (Discourse::InvalidAccess)
/var/www/discourse/lib/auth/default_current_user_provider.rb:67:in `rescue in current_user'

I am on discourse version b2cfad5 (or v1.8.0.beta5 +202 according to the dashboard).


#2

I am getting error 500s (hosted discourse) on and off too today.


(Sam Saffron) #3

This is actually this issue:

A side effect of one of my fixes, I reopened the original, lets keeps all discussion there.


(Sam Saffron) #4