504 error on trying to set a topic timer

I created a new topic. After a few seconds I tried to set a topic timer to automatically close after 7 days. The page just hung there for about a minute and then gave me a 504 error. I clicked OK to close the error and tried again, again it hung for about 30 seconds and then gave me an the same error. Also noticed while this was happening the site hung and didn’t respond to new requests until the 504 error was returned at which point it started responding to new requests.

The site is running 2.7.0.beta7 (bfa301bd7b)

When I opened the same topic in a new window I found that timer was set to 7 days (I don’t know whether it’s actually set or not, no idea how to verify it). If I go to the the sidekiq web interface, under Scheduled jobs I don’t see any job for 7 days.

Why it is giving me a 504 error ?

Sorry, what’s the steps to reproduce this? I am unclear.

It’s not consistently replicable. It’s happened only once so far. Create a new topic and set the close timer thereafter and it threw an error.

I guess the repro is the general:

Get overwhelmed with requests, or have a patchy network.

504 would probably come from NGINX or a proxy along the way.

I agree entirely we can do better here (globally). We should never say “504 error” to users, we should always say “We are having a problem contacting the server” or something like that.

@martin can you add to your list seeing if there is some sort of global fix here? Not urgent, plenty of more urgent things we have.