Hallo,
ich habe diesen Fehler erhalten:
Error response from daemon: driver failed programming external connectivity on endpoint app (2cf9494e875c2910beaf80edc21a16c997aba51b23504f26bd58e381b167f45f): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use
Error: failed to start containers: app
Weiß jemand, wie man das beheben kann?
Falco
(Falco)
23. Februar 2020 um 18:40
2
Versuchen Sie, Discourse auf einem Server zu installieren, der bereits für andere Anwendungen genutzt wird?
Da Discourse an die Standard-Webports bindet, empfehle ich die Verwendung eines brandneuen Servers für Discourse.
Was meinst du mit einem brandneuen Server?
Remah
(Just another happy Discourse user)
23. Februar 2020 um 18:41
4
Du kannst nach diesem Fehler suchen, der besagt, dass der Port bereits verwendet wird.
Du befolgst also nicht die offizielle Installationsmethode discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub
Und du brauchst wahrscheinlich dieses Thema:
Wenn du auf demselben Server, auf dem Discourse läuft, weitere Websites betreiben möchtest, musst du einen zusätzlichen NGINX- oder HAProxy-Proxy vor dem Docker-Container einrichten.
HINWEIS: Dies ist für fortgeschrittene Administratoren
Diese Anleitung geht davon aus, dass Discourse bereits funktioniert – falls dem nicht so ist, kann es schwierig sein zu erkennen, ob die Konfiguration korrekt ist.
Du kannst ./discourse-setup nicht verwenden, um Discourse einzurichten, wenn ein anderer Server …
Ich habe die offizielle Installationsmethode befolgt.
Gibt es eine Möglichkeit, die Ports zu ändern? Wenn ja, wie und auf welche sollte ich sie ändern?
Es heißt, die Seite sei ungültig oder privat.
Remah
(Just another happy Discourse user)
23. Februar 2020 um 18:47
8
Ich habe diesen Link von Google übernommen: Andere Websites auf derselben Maschine wie Discourse betreiben:
Wenn du auf demselben Server, auf dem Discourse läuft, weitere Websites betreiben möchtest, musst du einen zusätzlichen NGINX- oder HAProxy-Proxy vor dem Docker-Container einrichten.
HINWEIS: Dies ist für fortgeschrittene Administratoren
Diese Anleitung geht davon aus, dass Discourse bereits funktioniert – falls dem nicht so ist, kann es schwierig sein zu erkennen, ob die Konfiguration korrekt ist.
Du kannst ./discourse-setup nicht verwenden, um Discourse einzurichten, wenn ein anderer Server …
Ich bekomme auch diesen Fehler
nginx: [emerg] BIO_new_file(“/var/discourse/shared/standalone/ssl/ssl.crt”) fehlgeschlagen (SSL: error:02001002:system library:fopen:No such file or directory:fopen(‘/var/discourse/shared/standalone/ssl/ssl.crt’,‘r’) error:2006D080:BIO routines:BIO_new_file:no such file)
nginx: Konfigurationsdatei /etc/nginx/nginx.conf Test fehlgeschlagen
Ich habe bemerkt, dass der gesamte ssl-Ordner leer ist. Wie kann ich das beheben?
Außerdem wurde damit noch etwas anderes ausgeliefert
nginx: [warn] die Direktive “ssl” ist veraltet, verwenden Sie stattdessen die Direktive “listen … ssl” in /etc/nginx/sites-enabled/discourse.conf:12
Falco
(Falco)
23. Februar 2020 um 19:15
12
Wenn die Ports auf Ihrem Server blockiert sind, kann er ebenfalls keine Zertifikate erstellen.
Handelt es sich dabei um einen Digital Ocean Droplet? Ich empfehle, einen neuen mit Ubuntu 18.04 zu erstellen.
Ich habe Digital Ocean nicht installiert.
pfaffman
(Jay Pfaffman)
24. Februar 2020 um 13:25
14
Wo befindet sich dieser Server?
Es wird empfohlen, das Betriebssystem mit einer sauberen Installation neu aufzusetzen und sicherzustellen, dass keine Webserver (Apache oder Nginx) installiert sind.
danb35
(Dan)
24. Februar 2020 um 13:56
15
Wenn Sie diese Methode befolgt hätten, wären Sie nicht auf diesen Fehler gestoßen. Wo befindet sich Ihr Server (oder VPS), und welches Betriebssystem (und welche Version) ist installiert? Was else haben Sie auf diesem Server installiert?