Babble - A Chat Plugin

Hey @Iceman,

Babble doesn’t look at that setting, so TL0 users will be able to post in any chats they can see (we don’t have ‘view / edit’ level permissions on chats… yet?) You can of course prevent TL0 users from posting things in chats by making all of your chats accessible to TL1 or above.

1 Like

I’ve read through the thread as much as I could they are LONG! I am wondering if someone can summarize the security aspects of the plugin. I can’t seem to find a specific post on it.
Can I limit this to certain trust level users? can I limit it to certain categories only?

1 Like

Short answer: yes on all counts!

There are two types of chats, ones which are secured by categories, and one which is secured by one or more groups. You can create a chat available to everyone by assigning ‘trust_level_0’ as its group, or one available to TL2 and above by assigning ‘trust_level_2’ as its group.

2 Likes

Where’s auto-open function, will it be available?

1 Like

This is a stupendous plug-in. One minor quibble. Can admins delete the first post in a chatroom? I can delete or edit all subsequent posts except the first. For setting out chatroom channel rules or discussion guidelines for each channel, it is often helpful to edit them as circumstances change and hindsight comes into play. Having to go through and delete a chatroom, lose its entire history, and then recreate a chatroom just to make a new first post seems like a silly exercise. Otherwise, this is wonderful. This saves me the trouble of a separate chatroom (including processing overhead and moderation staff) from my forum.

Hey Guys

my Chat topic has reached 10000 posts and was closed by the system account.
Is creating a new chat room to replace the current one the only way?

Or is there a better seamless way?

Can you describe what ‘closed’ means here? Is it not letting you post further? What’s the behaviour you see after it hits the 10k limit?

Just installed the Plugin, getting the following Error when trying to create a Chat Channel

I have tried doing it for groups and or categories, same result. Any ideas?

Discourse Version: [v2.2.0.beta7 +126]
Bable: 4.0.9

1 Like

Same here, my chat channel dissapeared and now I cant create a channel :frowning:

1 Like

It disapeared from channel list, the hidden topic is still there. It happened after installing Rewind 2018 plugin

This is the Error in Logs page:

TypeError: Cannot set property postStream of [object Object] which has only a getter
at d (*************(My url)/assets/plugin-third-party-96bbae1010e85e9ba45891ca1906856e2a09c832d38b91657f6144e502e21303.js:1:18321)
at i.buildTopic (*************(My url)/assets/plugin-third-party-96bbae1010e85e9ba45891ca1906856e2a09c832d38b91657f6144e502e21303.js:1:11452)
at *************(My url)/assets/plugin-third-party-96bbae1010e85e9ba45891ca1906856e2a09c832d38b91657f6144e502e21303.js:2:20265
at Array.map (<anonymous>)
at *************(My url)/assets/plugin-third-party-96bbae1010e85e9ba45891ca1906856e2a09c832d38b91657f6144e502e21303.js:2:20232
at h (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:1869)
at C (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:3255)
at E (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:3148)
at e.invoke (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:11634)
at e.flush (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:10577)

Uncaught TypeError: Cannot set property postStream of [object Object] which has only a getter Url: *************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01

@gdpelican I’m running into this error when trying to start my local dev environment. Any suggestions?

~/.rbenv/versions/2.5.2/lib/ruby/gems/2.5.0/gems/railties-5.2.2/lib/rails/engine.rb:672:in `find_root_with_flag': Could not find root path for Babble::Engine (RuntimeError)

Hmm I’m not able to repro that one; are there other plugins installed that might be affecting this? What happens if Babble is the only plugin in your local dev env?


@Jose_C_Gomez @Juan_Adamuz can you respective (in a PM if you wish) send me a screenshot of your /logs page? Are there any errors relating to Babble in there?

It’s goofy. I blew out all the others except for the standard Discourse ones. I’ll do some more playing around with it.

I have the same problem like @Jose_C_Gomez and @Juan_Adamuz. I freshly installed 2.2.0.beta7, added the plugin but I was never able to use it.

Info:

    TypeError: setting getter-only property "postStream"
    Url: https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js
    Line: 2
    Column: 4846
    Window Location: https://MYDOMAIN/admin/chats

Backtrace:

d@https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js:2:4846
buildTopic@https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js:2:11253
setupController/</s<@https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js:2:21311
setupController/<@https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js:2:21279
h@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:1867
C@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:3251
E@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:3148
y</e.prototype.invoke@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:11632
y</e.prototype.flush@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:10577
v</e.prototype.flush@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:12675
q</e.prototype._end@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:17455
q</e.prototype.end@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:14007
q</e.prototype._run@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:17961
q</e.prototype.run@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:14643
a@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:5:8
e/i.success@https://MYDOMAIN/assets/application-772b01e4126e0c6cbc09e2aac38bfc77e026bc36bb576e7e12b85c1ccac81139.js:7:28513
l@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:2:7440
fireWith@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:2:8194
r@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:3:11644
n/<@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:3:16516

I cant, it says you are not accepting messages

@Juan_Adamuz Sorry about that; I’ve turned that setting back on temporarily. Should work now.

Same situation for me. No new plugin, just did an update through the admin on the site. Lost the chat and when I try to create a new one I get the can’t be saved error.

2 Likes

My guess is the rebuild as part of the installation is more the culprit here than the new plugin… since I ended up in the same situation with no other changes other than updating.

Has anyone figured out anything further with this? I’m having the same problems. I added babble, did a rebuild and it worked fine for about 6 or 8 hours. Then had similar problems as described here.