Babble - A Chat Plugin

It disapeared from channel list, the hidden topic is still there. It happened after installing Rewind 2018 plugin

This is the Error in Logs page:

TypeError: Cannot set property postStream of [object Object] which has only a getter
at d (*************(My url)/assets/plugin-third-party-96bbae1010e85e9ba45891ca1906856e2a09c832d38b91657f6144e502e21303.js:1:18321)
at i.buildTopic (*************(My url)/assets/plugin-third-party-96bbae1010e85e9ba45891ca1906856e2a09c832d38b91657f6144e502e21303.js:1:11452)
at *************(My url)/assets/plugin-third-party-96bbae1010e85e9ba45891ca1906856e2a09c832d38b91657f6144e502e21303.js:2:20265
at Array.map (<anonymous>)
at *************(My url)/assets/plugin-third-party-96bbae1010e85e9ba45891ca1906856e2a09c832d38b91657f6144e502e21303.js:2:20232
at h (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:1869)
at C (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:3255)
at E (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:3148)
at e.invoke (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:11634)
at e.flush (*************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:10577)

Uncaught TypeError: Cannot set property postStream of [object Object] which has only a getter Url: *************(My url)/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01

@gdpelican I’m running into this error when trying to start my local dev environment. Any suggestions?

~/.rbenv/versions/2.5.2/lib/ruby/gems/2.5.0/gems/railties-5.2.2/lib/rails/engine.rb:672:in `find_root_with_flag': Could not find root path for Babble::Engine (RuntimeError)

Hmm I’m not able to repro that one; are there other plugins installed that might be affecting this? What happens if Babble is the only plugin in your local dev env?


@Jose_C_Gomez @Juan_Adamuz can you respective (in a PM if you wish) send me a screenshot of your /logs page? Are there any errors relating to Babble in there?

It’s goofy. I blew out all the others except for the standard Discourse ones. I’ll do some more playing around with it.

I have the same problem like @Jose_C_Gomez and @Juan_Adamuz. I freshly installed 2.2.0.beta7, added the plugin but I was never able to use it.

Info:

    TypeError: setting getter-only property "postStream"
    Url: https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js
    Line: 2
    Column: 4846
    Window Location: https://MYDOMAIN/admin/chats

Backtrace:

d@https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js:2:4846
buildTopic@https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js:2:11253
setupController/</s<@https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js:2:21311
setupController/<@https://MYDOMAIN/assets/plugin-third-party-9cf7bdb52a16a3ea568c7f431e6a403311b66f381cf395696e82f7df3644c17c.js:2:21279
h@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:1867
C@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:3251
E@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:18:3148
y</e.prototype.invoke@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:11632
y</e.prototype.flush@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:10577
v</e.prototype.flush@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:12675
q</e.prototype._end@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:17455
q</e.prototype.end@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:14007
q</e.prototype._run@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:17961
q</e.prototype.run@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:9:14643
a@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:5:8
e/i.success@https://MYDOMAIN/assets/application-772b01e4126e0c6cbc09e2aac38bfc77e026bc36bb576e7e12b85c1ccac81139.js:7:28513
l@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:2:7440
fireWith@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:2:8194
r@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:3:11644
n/<@https://MYDOMAIN/assets/ember_jquery-cf9339810550f9c92505dfbb37362c58a4a8a83bcee2d99174547b01c06ed7d3.js:3:16516

I cant, it says you are not accepting messages

@Juan_Adamuz Sorry about that; I’ve turned that setting back on temporarily. Should work now.

Same situation for me. No new plugin, just did an update through the admin on the site. Lost the chat and when I try to create a new one I get the can’t be saved error.

2 Likes

My guess is the rebuild as part of the installation is more the culprit here than the new plugin… since I ended up in the same situation with no other changes other than updating.

Has anyone figured out anything further with this? I’m having the same problems. I added babble, did a rebuild and it worked fine for about 6 or 8 hours. Then had similar problems as described here.

Here’s what I did and have tried:

Just did a normal update of everything… docker, discourse, babble(think there were 3 commits). Everything fine prior, babble channel disappeared afterward and get the error when trying to add a new channel. I’ve tried a rebuild, same problem persists.

I decided to try and revert Babble changes as a test. I forked Babble and then reverted first the last 3 commits and rebuilt using my git. No difference. Then I went ahead and reverted back a few months just for the heck of it and rebuilt. Still in the same situation.

Just trying to help troubleshoot as best a noob can, but since prior versions don’t work either my gut would tell me it was a change in discourse that created an issue for Babble.

Yes I reckon that’s the case. I’m hoping to set aside some time this evening to put a fix together.

3 Likes

Awesome… James, if you have a preferred donation method let me know. I’d be glad to send a donation your way. Babble is an indispensable part of my community. It’s constantly wide open.

Alright, this should be fixed in the latest, let me know if any other issues crop up.

Thanks for the kind words; I’ve added a donation link here and to the README of the repo for any of the extra-kind souls out there who want to show support.

5 Likes

I’ll donate to you too James, Good Job and excellent support!

Excellent, cheers. That took care of my problems and all my previous channels were restored.

Thanks for the Fix!
Is there a way to select a series of Chat Posts and turn it into a Proper Discourse post? Say a conversation got started in Chat that eventually became something “postable” Could the admin / moderator have the ability toi select the related questions / replies and turn it into a post?

1 Like

What determines who shows up on this list? Most of these folks I’ve never spoken to before. Nor do they actively participate in the forum for the most part.

3 Likes

I’ve had both these same thoughts/questions myself.

3 Likes