Can't upload backup

That is frustrating.

The good news is that the settings are in the database, so if you install the plugin it’ll get the settings.

1 Like

I just reinstalled the server and Discourse and restored the backup.
If everything else is ok I can figure out which plugins I had installed.


I had to reinstall everything again because I ran into some problems.

  1. Do I need to finish the setup and activate my new account? Or can I just wait to build Discourse the first time with ./discourse-setup and restore the backup directly?

  2. After restoring the backup it seems that everything is ok (except the missing plugins). I don’t use the default theme but in the other theme the header is missing (after the backup was restored) so I can’t login. I tried to set in the Rails console the default theme Path of theme components - #16 by Osama but after that the site won’t load anymore.

How can I set my account to the default theme so I can lgin again?

You should be able to login using the [YourSite]/u/admin-login link :+1:

(and then swop your themes around using the admin panel as normal)


Once you have the backup restored and you’ve managed to log in as an admin, you should be able to find the plugins you were using by inspecting the site settings json file.

Open [YourSite]/admin/site_settings.json and search for "plugin":. You should find things like "plugin":"discourse-narrative-bot" which will tell you that you were using the discourse-narrative-bot plugin. That’s a built-in one so you can ignore that along with poll, styleguide, discourse-presence, discourse-local-dates and discourse-details.

Note that plugins you installed in the past and later removed will also be there so this won’t necessary make a list of all the plugins you were using at the time of creating the backup, rather all the plugins you had used in the history of that site.


Thank you for your replies.

Now I have the problem that I can’t enter the site, only per SSH at the moment. Don’t know what the problem is or if the Hoster have a problem atm.

What happens when you try and access your site? Can you get to it using safe-mode? [YourSite]/safe-mode

Could you try re-restoring the back-up file from before you tried to change the theme via the rails console? And then use the admin-login or safe-mode to bypass the theme instead?

I can’t even ping or traceroute the site, only per SSH.

Sorry for the delay, I had problems with my domain but I switched to another one and I could successful restore the backup and login.
Now almost everything is ok but I have one more question.
After the restore I have an notfication that no email notification will be sent anymore. Where can I change this? I have searched in the whole admin area but couldn’t find anything.
This is the text I see at the default page:

Outgoing email communication has been globally disabled by an administrator. No notifications are sent by e-mail.

I tried this but I can’t see the “old” plugins which were installed. Only the current plugins.

That will be the ‘disable emails’ setting:

1 Like

Yes, that was it! Thank you! :+1:

1 Like

So, after the backup was restored almost everything works as it should except some things aren’t as they were before.

For example I had in the “old” forum the solved plugin installed, and the solved button was where it should be like here on meta (on the left beside the like button). I would like to show you a screenshot but I can’t upload an image and I don’t know why.

In my forum the solved button is hiding behind the 3 dots and it appears only when someone is clikcing on the 3 dots, but no one is clicking the 3 dots.

So how can I can change the place of the solved button?

For my forum, the Solved box appears outside the on my topics, but gets hidden inside it when I’m not the OP but can still mark a solution (eg. because I’m staff).

Have you checked with a test user that you’re seeing what a non-staff user sees?


OMG you’re right and I’m dumb as f… :grinning_face_with_smiling_eyes:
Thank you! :+1:

1 Like