Connection to the POP3 server is failing with an authentication error. Please check your POP3 settings

It looks like Google has changed POP3 access and this has led to my instance failing to poll messages after running smoothly for 5 years.

I found an older fix for this here: Gmail POP3 authentication failed — switch to application password . I followed the gmail link provided in order to switch the service to application password only but it seems Google adjusted their policy on May 30 2022.

Can anyone kindly advise how Gmail Pop3 should now be setup in Discourse?

1 Like

I recommend turning on 2FA on the account and setting up an App Password for Discourse. The policy change is about the “allow less secure app access” option being deprecated. More info on this here:


Thank you, That’s now working :+1:.

A warning for anyone else going through this - Google will likely fire off security alerts. The algos went as far as auto-dumping my first attempt :roll_eyes:.

Check the inbox of the gmail account you’ve setup as you go through this process so you can confirm to their algos that is you performing the changes.


Thanks @JammyDodger for pointing me towards this topic.

I have the same problem that @Amicable reported here.

Can I just check the process?

I enabled 2FA on my gmail account. This then revealed/added the option for me to create App Passwords at

I then created a new app, and copied the 16 digit password.

I checked my inbox and saw the security emails you mentioned, I followed them through and confirmed “it was me”.

Then I went to my Discourse settings and changed the pop3 polling password setting, removing the old password and replacing it with the 16 digit app-password.

Is there anything else I need to do? I’m now seeing this is my logs:

Job exception: -ERR [AUTH] Application-specific password required:

Have I missed something? :thinking:

Do I need to restart anything?

1 Like

I waited some time, this seems to have rectified itself.

Thanks for the info here everyone :smiley:


Hopefully the delay/wait solves my issue also. It shows that it connected…

…but it’s still not yet showing anything new in Gmail Sent items.

Error: 535-5.7.8 Username and Password not accepted

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.