Custom Homepage for Groups

From what I see, @pfaffman introduced incomplete code in his last change (likely unintentional; see the two conditions without closing brackets) :thinking:


Darn. I added broken back. I’ll have a look next week and see about adding tests though I’d think that should have been caught by the linters.

Sorry folks


I think this time I’ve really fixed it!

And I added tests, so next time I try to commit code with errors in it, I’ll get an email from github, hopefully before anyone else notices.

EDIT: Ooops. That was a different repo that was passing the tests, but I sholud have it sorted in a few minutes.

EDIT: Well, I think the code works, but it’s still not passing tests as whined about here: How to convince eslint that settings are defined? wah

Thanks to @CvX (How to convince eslint that settings are defined? - #5 by CvX) the day is saved.

I can’t remember who once paid for this, but they aren’t paying now. If you’re finding this useful, you can give me whatever it’s worth to you via methods on my not yet launched new web site.


No worry, Jay! Thanks for the fix.

Also, if you have not seen it yet, you left debug messages in the code. :smile:


I’m getting the following error on the latest build, but only when viewed as anonymous and it prevents the site from fully loading:

1 Like

That would be me! I’m not actively using it at the moment, though.

Thanks David for the report.


Aha! That would explain why you’re who posted this topic!

Bummer. I sort-of thought that the last changes might have gotten things up to date.

I do something similar on my dashboard, so there’s a decent chance I’ll stumble upon the solution to this sometime soon. To make it a higher priority, please contact me with a budget.


No rush here Jay, I was only using a very tiny feature of it that is not important at all.


So, I set the anon setting to /home but when I refresh the page while signed out, I get this at the base directory at

It isn’t a private page and works fine when signed in. Had someone else verify they can also access the direct URL as a guest.

1 Like

There is no such url as /home/, just make it be /?


1 Like

This is the /home page.


If you send me your URL I can take a look.

1 Like

PM sent! Thank you.

Hey @pfaffman - does this mean that we need to change this TC a bit?

1 Like

If it matters, I still have my above issue with this component.

1 Like

That’s not immediately apparent.

Perhaps it’s related to this?

I think the thing to do is upgrade and see if it’s broken.

I think that the theme component that adds the route should change the home page as described in the commit. Do you want the home page to change for all users or just some?


Hi, still broken.

Anyone who isn’t signed in to an account. The anon users.

1 Like

Darn. Well, I’m not sure if it’s the other theme component or this one to blame and it’ll take me a while to figure it out.

If someone with a budget has trouble with it I’ll see what I can do to figure it out.

1 Like

Sounds good!

1 Like

This is pretty cool with the sidebar “all categories” pulls up the regular category page.

Only caveat is it seems to block the search banner until primary group changed back.

Wondering if this could be made to be compatible so it shows on custom home page & main category page without switching primary group?

I am using Air theme. When "all categories clicked on in side bar the modern Category boxes&groups shows. Just without the search banner

Definite game changer

1 Like