Deep linking (headers) isn't working for my site in Firefox?

Hi,
I try to structure a longer post with deep links like Deep Linking to Headings (Anchors).
But there is no reaction of Firefox to clicks to the links.
It would be helpful as anybody can explain to me what is wrong or missing.

Here the relevant code example snippets:

  • in the first paragraph :
    :warning: Don’t forget: you have to activate ([how to see below](#heading--linktest)) the *Share Publicly* option :exclamation: Otherwise the Station ID is only useful for[...]
  • and ths last words :
    [how to see below](<absolute link including https:// until the number of topic>/1#heading--linktest))

the anchor is somewhere in the middle:

<h7 id='heading--linktest'>Link to </h7>
* next pint 

I tried for the anchor as well seversal differnt h#-versions and
<a id='heading--linktest'>Link to </a> with and without any text between '> and </

Does the link in that post work Deep Linking to Headings (Anchors) for you?

I just tested in Firefox, both anon and logged in, and the link in the above post ↑ behaves as expected.

Can you confirm the same?

1 Like

Yes, the link in the original post woks as expected.

Is there an option or plugin which has to be set / activated?
The non-working example is in a different instance.

Do you have an idea to that issue, beside modifying the title of the topic, which is now ore precise,o.k.

Question: where do you compose your code? I did a batch of coding in Google docs (working collaboratively) and totally forgot about the curly quotes. Programs like docs will autocorrect that, and curly quotes are NOT the same as straight quotes.

I banged my head against that code for an hour before I figured out the problem.

I used the editor included in the discourse platform and actually used a German keyboard layout so it might be an issue of character encoding.

Right now, I tried to make a private message here within the relevant snippets.

Even no expected behavior, as well. @codinghorror so the “my site” in title is not appropriate. Modify again?
Maybe @eviltrout has an idea?
Does someone want to have a look to that (private) test topic here?

The other way around: copying the raw code of the original topic to a new private topic on my site shows the expected behavior. So, it is probably no configuration, version or plug-in issue.

Maybe, I figured it out :
The h7 tag is not defined?
The anchor at a h6-Tag works as expected, at a h7 nothing. This is the same for the <a>.
The <h6> acts as expected even if it is without any text to be displayed. Then the issue of the “heading gab” still remains (independent of h-level).
So for inline anchors <a name=“anchor”></a> is the way to go? … but will not act as expected in my case.

AFAIK there is no such thing and 1 to 6 is the range.
https://www.w3.org/TR/2011/WD-html5-author-20110809/the-h1-h2-h3-h4-h5-and-h6-elements.html

I suppose it might be possible to put together a custom DTD but IMHO it would be easier going sticking with valid HTML

1 Like

Indeed, we only support h1 to h6 in our code:

3 Likes

O.K.
Maybe don’t see the point or have to change the structure of the post completely.
I tried several ideas to use a <a>-Tag with an id or name option to set an anchor to jump to. But on both instances there is no apropriate action.
Is the general id-Option implemented ?
How would an eample look like?
Do I miss anything ?