Device "docker0" does not exist

I just tried to install discourse on my dedicated ubuntu server. I followed this tutorial:

of course I do not have a cloud or anything, but my server. I guess it should work anyways.

I am using the terminal of my mac. Here is the problem. After typing in:

./launcher bootstrap app

I get an error:

Device "docker0" does not exist.
Cannot connect to the docker daemon - verify it is running and you have access

What can I do? I thought everything went well until this point. Any ideas?


that means that the doctor install did not work. What happens if you run docker info?

Get http:///var/run/docker.sock/v1.19/info: dial unix /var/run/docker.sock: no such file or directory. Are you trying to connect to a TLS-enabled daemon without TLS?

Your docker install is failing. You should look into why Docker is failing to install on your OS. This is usually because the OS is not 64 bit, or the kernel is too old, etc.

We recommend Ubuntu Server 14.04 LTS x64.

1 Like

I’ve got exactly the same problem, and have been following the same tutorial. docker info provides the same information that @Fabian has mentioned.

I’m running the suggested build of Ubuntu and can confirm that I’m on a 64bit version of it. I’m not really experienced with Linux but I couldn’t see any anything that looked like an error during the install of docker. The only thing that I’m aware that I did do which was off script was to add myself to the docker group as per the installer suggestions using:

sudo usermod -aG docker {USERNAME}

Are you not logged in as root when you install Docker via

wget -qO- | sh

As per the official install docs?

Jeff - appreciate you trying to help with this.

So the wget command you listed is exactly as I ran it. However looking at the images in the docs (and you referring to root) they’re running under the root@forum user. Mine wasn’t run under root (I actually read you can’t access root on Ubuntu so I’ve been using the admin account I created ian@Ubuntu and using sudo when hitting permissions errors.

It should work if you’re a member of the docker group.

1 Like

Yeah, so I believe I did that with the command I mentioned in post #5

sudo usermod -aG docker {USERNAME}

I really have no idea how you can login as root. I mean I did “ssh” so I guess this should be it. Still not sure why it isn’t working then. :frowning: I can’t wait trying discourse out :wat:

by the way, I found out that my kernel is 2.X. so I tried to upgrade it. But it doesnt work either:

apt-get install linux-image-generic-lts-trusty
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package linux-image-generic-lts-trusty

edit: now somehow i got a new kernel 3.18… but i keep getting errors when trying to install docker :frowning:

so what am I supposed to do right now? no chance to install discourse?

You need to get docker working on your server first, perhaps submit a support request on

Unfortunately, they do not reply. No support on their forum. Will there be another way to install discourse in future? Why is it, that you have to install docker etc.? Discourse is the first software with such complicated install I met, so far all I had to do were some simple clicks on install and upload via ftp :smiley:

You could install on Digital Ocean, that works well for us.

I’m on Ubuntu 15.04 and had to run service docker start to get the docker daemon running and then I could bootstrap without issue.


I faced that error some minutes ago…
After reviewing my actions I discovered that I updated the lxc-docker from 1.5 to 1.7 in the VPS with ubuntu server…
So I did:

apt-get update && apt-get install lxc-docker-1.5
then sudo reboot

That removes the newest lxc-docker, that causes a conflict with the driveimage storage method and prevents the docker daemon to start correctly.
It is for sure not the cleanest solution, but is fast and safe for the moment.



In my case, it turned out to be that the docker daemon was not running, and was not started at boot time. Check your OS manual for instructions on how to start this daemon.

1 Like

Hi. I got same thing as you. I ran ‘service docker start’ and every thing work find then.


I built success but how to develop this source and how to deploy to server?

oh yes , u are right .