Disable live notifications?

Is there a way to properly disable live notifications? For some forums I don’t want popups for new posts. But still every time I go to the forum it says at the top

Do you want live notifications when people reply to your posts?

The answer to that question is “no”, but discourse stubbornly refuses to take that as an answer – I have dismissed that question a dozen times now and it keeps coming back.

How do I make it stop?

(I don’t admin that instance myself so I do not know which version they have installed.)

Go to your preferences -> notifications and disable this ‘live notifications’

Yeah that’s where I went, but there it only offers to enable notifications:

They might be on older version

1 Like

It says “Discourse 2.4.5”.

Instead of dismissing the pop up, you should be able to click the ‘Enable Notifications’ button, then when your browser prompts you, click ‘Deny’ (or your browsers alternative). Discourse should register this and stop asking you. It will also change your settings to look like this:


Thanks, that worked.

I still think there is a bug here though: in order to permanently disable notifications, I had to click “enable notifications”. That is not exactly intuitive. :wink:

Actually, I have to take this back. After restarting my browser and logging in again, the request to enable notifications is back. Discourse really doesn’t take “no” for an answer…