Disable two factor auth with only backup codes

Hello everyone,

I recently had to reset my phone so I lost all my Google Authenticator codes (for Two-Factor Authentcation)

I have backup codes so I can log in to my Discourse accounts but I cannot disable/update two factor auth from my account.

Is there a way to do it that I missed?

Thanks for all the help!

If you can log in (you kept backup codes, excellent work), you can disable two factor. Just edit it in your user preferences.

I tried, it asks me an authentication code (which obviously I don’t have) and it doesn’t allow me to input one of my backup codes on the input field (It only allows 6 characters)

2 Likes

Our CSS there looks a little messed up cc @Johani. Worth a check.

I thought the backup codes worked the same as the app codes, is this not the case @nbianca?

2 Likes

@codinghorror authentication codes from apps are 6 character longs while the generated backup codes are 16

2 Likes

The other option is to have a staff member disable 2FA on your account, but I agree we should fix this up since you’re currently stuck.

2 Likes

Hope I’m not asking a lot but can we do both? I’d like to be able to access my accounts ahaha

Actually, @maja can you take a break from the Ember 3.7 upgrade and ensure we can disable 2FA using either authentication or backup codes?

5 Likes

This has been fixed per this commit:

Sorry for the inconvenience @tajchumber

7 Likes

Now it works like a charm! thanks @maja :slight_smile:

5 Likes