Disabling SMTP SSL verification still not working?

hi folks - following Disabling starttls or certificate verification does not work any more - #4 by flink91 I thought / hoped that DISCOURSE_SMTP_OPENSSL_VERIFY_MODE might be back in service, but even with it set to DISCOURSE_SMTP_OPENSSL_VERIFY_MODE=none we’re still seeing SSL certificate name mismatch errors.

anyone else also experiencing this? disabling TLS isn’t an option in our scenario, neither is accessing it via its main certificate name. and, if so, is a fix planned anytime in the foreseeable?