Discourse as SSO provider: "sso secret" vs. "sso provider secrets"


#1

My site SSO has been broken since the introduction of the sso provider secrets setting. To fix it, I needed to move my sso secret from the sso secret setting to the sso provider secrets setting.

So, as far as I can tell, the sso secret setting has been replaced by the sso provider secrets setting with no backward compatibility. Am I right?

If I am, then a UI bug remains: in the enable sso provider setting, “…requires sso_secret to be set” should be replaced by “…requires sso_provider_secrets to be set”


(Sam Saffron) #2

“sso provider secrets” is only there IF you are using Discourse as an SSO endpoint. If you SSO implementation is NOT discourse you do not need to fill anything there.

Not this is not the case

Can you please upgrade to latest ASAP and let us know if the issue remains. sso provider secrets should be blank for you UNLESS you are using Discourse as an auth provider for another Discourse site.


(Régis Hanol) #3

We do have a migration that copies the sso secret into the sso provider secrets site setting so I’m curious to know why yours wasn’t copied over?


(Maja) #4

This was outdated indeed after sso_provider_secrets site setting was introduced. I have updated the text in FIX: sso provider copyedit · discourse/discourse@5485248 · GitHub


#5

Sorry to be late on this.

@sam, I am using Discourse as an auth provider for another Discourse site.

@zogstrip, how can I help you identify why the migration didn’t work for me?