Discourse Connect does not auto login anymore

I have the following set up:

  1. WordPress as the main site with Discourse Connect setup using WP Discourse
  2. Discourse as the child site where login and registration only happens from WordPress instance.

Earlier:
When user registered on main site and then clicked on community domain they were automatically logged into Discourse.

Now:
The user registers on main site, clicks on community url and then has to click again on the login button on Discourse to log in the community. Discourse does not ask for any login information so it is getting the details from Discourse connect.

For some reason, the auto login has stopped working. This is not the best user experienced as the two sites should be in sync. What could I be missing?

1 Like

Does your community url have this at the end? /session/sso?return_path=/

Adding this has solved all of my problems. Also, have you tried another browser? I recently had this issue and it turns out it was caching issue or something and the users were not actually having a problem, just me.

3 Likes

Thanks David. I cleared the browser cache and checked again but still have the same issue.

Here is a video and here are my Discourse connect settings. I recently installed guest gate but even after disabling it the issue still exists. Beyond that, I have not made any changes to the settings.

Any suggestions to fix this?

You missed the bit about adding to the URL. I just tried it on your site and it worked. Your community URL needs to be https://community.showprowess.com/session/sso?return_path=/

3 Likes

Oh wow. I read it wrong. It was working before without this setup.

Let me make the changes. Thanks David!

2 Likes

Same here, when I first created my site I had to use this, then I didn’t for a couple years, now in the past couple months I had to start using it again :man_shrugging:t2: