WSLがDocker Desktopに接続せず、ホストの/var/lib/dockerを直接使用しようとする問題について

はい、チュートリアルに従って住宅回線でDiscourseを実行できるようになった後、私のインスタンスは非常にうまく動いていました。

Linux関連の処理はWSLを使って対応しています。インスタンスは主に実験用です。WSLにDockerを導入する手間を省くため、Windowsホスト上のDocker Desktopアプリに接続しています。

最初はうまく動いていましたが、突然動かなくなりました。

./launcher rebuild appを実行すると失敗し、/var/lib/dockerが存在しないというエラーが表示されます。

ランチャーはこれを5GB未満と判断し、空き領域を確保しようとして、その後失敗します。

何か手がかりはありますか?

WSLは開発用ですので、公式のインストール手順ではなく、開発用にUbuntuまたはDebianでDiscourseをインストールするの手順に従うことが前提です。