Discourse Setup Error

Hello there! I was just setting up Discourse on my virtual private server and the configuration setup was a success. Then I got the error ERR_CONNECTION_REFUSED when opening the web page in my browser. I was wondering why this wasn’t working. Then I did some studying and found this command, ./launcher logs app. I ran it in my SSH and everything looked fine, then I found a red error in that. I will put the error below as it is quite large.

[Tue 21 Dec 2021 08:23:26 AM UTC] forum.twobrake.xyz:Verify error:Invalid response from http://forum.twobrake.xyz/.well-known/acme-challenge/S78Gyo7aMOkevqjQJ7iFtMgJ-McbBeMUKNIDZVUZzHw [2a02:4              780:b:649:0:df1:f56b:1]:
[Tue 21 Dec 2021 08:23:26 AM UTC] Please check log file for more details: /shared/letsencrypt/acme.sh.log

Now I am just wondering how to fix this error. Can anyone help me with the information I have provided above? If not, just let me know and I can try to provide more information if needed. Thank you in advance!

Did you run discourse-setup? It checks that your hostname resolves to your virtual machine.

But if you did many rebuilds before let’s encrypt was able to connect then you’ve been rate limited and will need to wait a week, use a different host name or cheat by adding a second hostname as described at

Setting up Let’s Encrypt with Multiple Domains

I have ran the ./discourse-setup command twice or three times only. Would that cause it to be rate limited?

New error when I ran ./launcher logs app again.

PEM_read_bio_X509_AUX() failed (SSL: error:0909006C:PEM rout                                    ines:get_name:no start line:Expecting: TRUSTED CERTIFICATE)

Any idea what this one means?

I think is is actually just the rate limit. I have followed the steps above on connecting another domain to my website to use Discourse on, and I still seem to get the error, ERR_CONNECTION_REFUSED. I followed all the steps correctly on the documentation you sent me. Are there any other steps I need to take after configuring the app.yml file?